Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

so I ran

apt-get update; apt-get dist-upgrade

the upgrade failed and I lost the gui, I have an encrypted /home drive.

When I run apt-get * (any command) I have all kinds of errors mostly missing depends and thats because apparently my network stack is gone.

I have no NIC if I run ifconfig. It doesn't even show up with lspci

If I were to do a "clean" install of 10.04 LTS which is what I had on my on my build, will I lose all my data?

BTW I was just using Ubuntu's default encryption to manage the encryption using my PSWD as the key so if I were to use the same user name and PSWD would my data be accessible?

I can see my data from command line, when or if Xorg does start it just loads a basic window with nothing but a black X in the middle of the screen which I can only assume is my mouse cursor but it doesn't move!

Reddit /r/linux had some ideas none of which worked was, no help. And apparently /r/ubuntu is full of jerks because all they did was ridicule me.

If I can get my install back I probably will be switching back to either Slackware or Gentoo. The Ubuntu forums were of no help they had the same suggestion as /r/linux. I am about to just run my back up script to my back up drives and nuke everything else but I'd rather not.

share|improve this question
    
What is the exact apt-get error? We'll try to help you here. –  hexafraction Nov 15 '12 at 22:46
    
libqt4-sql-sqlite : Depends: libqt4-sql (= 4:4.8.1-0ubuntu4.2) but 4:4.8.3+dfsg-0ubuntu3 is installed Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.2) but 4:4.8.3+dfsg-0ubuntu3 is installed libqt4-test : Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.2) but 4:4.8.3+dfsg-0ubuntu3 is installed –  diefuchsjagden Nov 15 '12 at 23:12
    
libqtgui4:i386 : Depends: libtiff5:i386 (> 4.0.0-1~) but it is not installed but 4:4.8.3+dfsg-0ubuntu3 is installed Depends: libqtcore4:i386 (= 4:4.8.1-0ubuntu4.2) but 4:4.8.3+dfsg-0ubuntu3 is installed E: Unmet dependencies. Try using -f. to get that I just chrooted into what was my root drive from a live 10.04 disk –  diefuchsjagden Nov 15 '12 at 23:13
    
qdbus:i386 : Depends: libqt4-dbus:i386 (= 4:4.8.1-0ubuntu4.2) but 4:4.8.3+dfsg-0ubuntu3 is installed Depends: libqt4-xml:i386 (= 4:4.8.1-0ubuntu4.2) –  diefuchsjagden Nov 15 '12 at 23:13
    
Please edit any additional information into your question. –  user76204 Nov 16 '12 at 1:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.