Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed a fresh Ubuntu 12.10 64-Bit Desktop on my Lenovo W520. It looks like there are a lot of challenges around making it work with out of the box Nouveau drivers or propriety Nvidia drivers or Intel GPU. I looked at couple of notes on how to make it work with Bumblebee with Optimus Nvidia. None of them seems to work for 12.10. Anybody has a solid answer on this? It seems like a lot of people are suffering from this.

Here is my xrandr output. Let me know if you need any additional information.

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
LVDS1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x    193mm
1920x1080      60.0*+   59.9     50.0  
1680x1050      60.0     59.9  
1600x1024      60.2  
1400x1050      60.0  
1280x1024      60.0  
1440x900       59.9  
1280x960       60.0  
1360x768       59.8     60.0  
1152x864       60.0  
1024x768       60.0  
800x600        60.3     56.2  
640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)

Thanks, Sef

share|improve this question
add comment

2 Answers 2

The bios option Optimus uses the integrated (Intel) driver on battery power and the discrete (Nvidia) driver for additional displays and more video intense applications. Ubuntu can use the Bumblebee package with the Optimus setting to leverage this feature.

12.10 Bumblebee Option

In Ubuntu 12.10 to install Bumblebee on a Thinkpad W520 first set the bios video option to Optimus, and disable optimus detection.

  1. sudo add-apt-repository ppa:bumblebee/stable
  2. sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
  3. sudo apt-get update ; sudo apt-get upgrade ; sudo apt-get dist-upgrade
  4. sudo apt-get install bumblebee bumblebee-nvidia
  5. sudo reboot

12.10 NVIDIA Proprietary Option

Note: I found this option has better multiple monitor support and higher graphics performance all the time, but less battery life than the Bumblebee option.

I ended up using the Nvidia proprietary driver (64-bit): NVIDIA-Linux-x86_64-310.19.run so that I can use the 2 displays attached to my laptop docking station. First downloaded it, then added this to my /etc/default/grub file:

GRUB_CMDLINE_LINUX_DEFAULT="nox2apic"

and then ran 'sudo update-grub' so the change would stick.

Then to install the NVIDIA driver I rebooted and switched the BIOS video setting to 'discrete' and disabled the optimus detection. On bootup I had to hold down shift and choose from the grub menu the recovery option, added network support and then chose a root prompt so I could install the NVIDIA drivers with the discrete driver in play, but before the desktop tried to load:

sudo chmod +x NVIDIA-Linux-x86_64-310.19.run
./NVIDIA-Linux-x86_64-310.19.run

I took the defaults, including the suggested nvidia-xconfig option at the end. Then on reboot it worked, and monitor configuration is done with nvidia-settings dialog once in the desktop.

share|improve this answer
add comment

I have a w520 with a quadro1000 and had an issue with optimus under 12.04 and the display port output. You need to go into bios and force the graphics device to discrete graphics and also disable OS detection for nvidia optimus. I had to set both, just selecting discrete graphics was insufficient.

I'm submitting this on an external display via displayport with the 12.10 live boot.

Image search "w520 optimus bios" first hit shows you the settings. As far as I can tell optimus mode just leaves you in the integrated intel video that doesn't hook up to the display port.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.