Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently purchased a Lenovo G580 laptop. Make of the ethernet card is Atheros. Unaware of the version: one of AR813x. I'm unable to configure ethernet[wired network] on the same. Wicd was turned on by the supply of these commands in the terminal:

/etc/init.d/wicd start

/usr/bin/wicd-client on

ifconfig

I've gone through the rest of the forums as well and found that Lenovo G580's ethernet configuration issues can be nullified by installing one of the compat drivers said by many. I've tried running many packages.

And sometimes when i give the command to access the folder which contains the compat files, it gives me an access denied statement.

I've been trying since a week reading lots of forums, but no luck. Nothing's working.

share|improve this question
    
What happens when you try to configure the Ethernet network from Network Manager? –  Aaron Nov 15 '12 at 19:41
    
My wireless lan is showing up as wlan0. and another "lo" is listed. No sign of any eth0 or eth1 .This is from the terminal. –  Romulan Nero Nov 15 '12 at 20:25
1  
Please run lspci -nn and edit your question to add the Atheros ethernet details. It sounds like no driver is installed yet. –  chili555 Nov 17 '12 at 13:37
    
Hey! thanks ! I got it. I ran a random update driver from three compat drivers and had my eth0 working! –  Romulan Nero Nov 18 '12 at 7:22
    
What did you update exactly? –  hithwen Feb 9 '13 at 14:36
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.