Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have used my old BT Home Hub with no problems. But now I have upgraded it and it works fine on my Windows laptop but although Lubuntu sees it, it cannot connect and is stuck on "Obtaining IP Address". No problem with both HTC Explorer's (Android) so not just Linux. I am using ndiswrapper, by the way.

share|improve this question
add comment

1 Answer

Found the answer from here. You need to change the connection to the hub from dynamic to a static IP address. Something about DHCP problems.

Method (This is for Ubuntu 11.10 but should be almost identical on other Ubuntu versions):

  1. Attempt to connect to your Homehub connection, this will fail but don't worry.

  2. Click the WiFi symbol and select "Edit Connections..."

  3. Click on the "Wireless" tab.

  4. Select your Homehub connection from the list and click edit. (Alternatively double click on the connection)

  5. Select the "IPv4 Settings" tab.

  6. For "Method", Select "Manual" from the dropdown box.

  7. In the "Addresses" Box, for "Address" enter 192.168.1.xx Where xx is a number (If you want to keep it out of the default DHCP pool, then set the last number between 2 and 63 or 200 and 253)

  8. For "Netmask" enter 255.255.255.0

  9. For "Gateway" enter 192.168.1.254 which should be the IP address on your network of your homehub. (It definitely is for HH2)

  10. In the "DNS servers" box enter 192.168.1.254 which is again your HH IP.

  11. I then deselected "Require IPv4 addressing for... complete".

  12. Leave IPv6 on "Automatic" as this does not seem to cause issues for connection.

  13. Save the settings and then click the WiFi icon and try and reconnect to the HH network.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.