Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Acer Aspire 5750 and if i let my computer sit for 4hrs - 48 hrs, when i open up the laptop lid, my screen is black. The computer is still on, but it won't wake up.

I use Ctrl+Alt+L to lock the computer.

Any help will be appreciated

edit*

this computer has the 2nd gen intel core i5 sandybridge integrated graphics. I had the same problem on 12.04 and 12.10.

share|improve this question

closed as off-topic by bain, Eric Carvalho, nux, Warren Hill, LnxSlck Jul 16 at 13:38

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – bain, Eric Carvalho, nux, Warren Hill, LnxSlck
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Have you tried aceracpi. Have you tried apt-get install acpi acpid? –  earthmeLon Mar 26 '13 at 15:39
    
Also an issue on my Lenovo IdeaPad Z570, although I'm pretty sure it is a bug and so I don't think this is the best place to put it. The workaround I found is to hit CTRL-ALT-F2 to bring up a terminal, login there, then type 'sudo pkill -kill -u <username>'. This should bring you back to the login screen. You will be logged out and lose work, however. –  Alex Apr 23 '13 at 17:01
    
I have a Toshiba s1000-z2 that has the same sort of problem. However, I know that my problem lies with the sensor that detects that the lid is shut. In my case this is a small switch that is pushed down when the lid is closed. When I hold a medium brightness slightly tilted upwards to the screen I can still see it. It seems that only the backlight is turned off, and not the LCD itself. Try holding a flashlight. Wiggle the mouse first though. Can you see anything? –  Edir Jan 12 at 9:29

3 Answers 3

Have you tried to change brightness (press the brightness up button)?

I can't find the links right now to post here, but there are reports that in some laptops when opening the screen lid again the brightness is minimum, in some cases it's like the screen is black. Pressing the brightness up solves in those cases.

Also there are scripts to automatically turn brightness up when keyboard shortcuts are not available or do not work.

share|improve this answer

@earthmeLon suggested to execute

sudo apt-get install acpi acpid

in a terminal. I had a similar problem, and that solved it. I would like to hear the result of this attempt, since you haven't posted that yet.

EDIT: Or actually sudo apt-get install acpisolved it for me, acpid was already installed.

share|improve this answer

i have had a similar issue it was fixed by installing my GPU drivers from the manufacturer. but i went to my laptop manufacturer and found a complete linux driver pack with rpm and autoconf downloads.

here is the link to the drivers page for your laptop unfortunately i cant link directly to your laptop but they have only windows drivers. us.acer.com/ac/en/US/content/drivers. i also could not find third party linux drivers for your laptop. you probably have mesa (which means table in spanish) nut it is a gnu compatible version of openGL i would recommend updating/installing other packages for mesa.

sorry i could not be of further assistance.

okay lucio this is an unconventional fix but you could try this:

GRUB_CMDLINE_LINUX=""

to this:

GRUB_CMDLINE_LINUX="quiet splash acpi_osi=Linux acpi_backlight=vendor"

in the file /etc/default/grub, then:

sudo -i

update-grub

this adds brightness adjustment but still no fix for the screen to turn on. it seems this is a very common issue with acer aspire series.

share|improve this answer
1  
If your link have only links to Windows drivers, than this "answer" should be removed. Beside the link, this doesn't seems to be helpful. –  Lucio Dec 19 '13 at 4:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.