Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my Hp Pavillion dv6 6155-tx everything is working just fine except for the Bluetooth. I have pretty much tried every bluetooth software out there but none seems to work. It seems that the driver is not installed or something like that. When i search for new devices it just dont find any device and the vice versa. Please kindly help me ! I am frustrated for more than 4 months now searching for some answers.

The output of rfkill list :-

0: hci0: Bluetooth

Soft blocked: no
Hard blocked: no

1: phy0: Wireless LAN

Soft blocked: no
Hard blocked: no

2: hp-wifi: Wireless LAN

Soft blocked: no
Hard blocked: no

3: hp-bluetooth: Bluetooth

Soft blocked: no
Hard blocked: no
share|improve this question
    
I had the same problem like Mr. Arin Chakraborty and tried a lot to fix it. But with his prescription, bluetooth starts like a magic. Thanks Mr. Arin. You made my day brother. –  user140513 Mar 15 '13 at 12:17
    
Glad it helped. You are very much welcome bro. –  Arin Chakraborty Apr 4 '13 at 17:56

2 Answers 2

up vote 1 down vote accepted

Ok finally i did some research and i was able to solve the mistery of the BLUETOOTH not working.

As per this - https://bugs.meego.com/show_bug.cgi?id=3498 the the radio was OFF all the time.

so to turn on the radio as they said - sudo bccmd psset -s 0x0000 0x028c 0x0001

and then i did - sudo service bluetooth restart

followed by a restart of the computer and then pressing the NETWORK BUTTON(f12) ON/OFF button twice to disable and then enable it and guess what it worked like a charm i can now connect everything.

share|improve this answer

Install synaptic form the Ubuntu Software Center

In Synaptic select bcmwl-kernel-source and bcmwl-sta-source

Then install it.

share|improve this answer
    
It Does not work, just an information that my bluetooth is ralink. –  Arin Chakraborty Dec 8 '12 at 20:19
    
ralink ? im turkish i dont know what this word means . –  user84277 Dec 10 '12 at 14:01
    
ralink/motorola, it's the manufacturer of my bluetooth module. –  Arin Chakraborty Dec 10 '12 at 20:16
    
i'm sorry it works for broadcom –  user84277 Dec 11 '12 at 4:47
    
Thnks anyways friend ! –  Arin Chakraborty Dec 11 '12 at 12:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.