Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having horrible problems with the latest ATI Graphics Driver. I have an ATI Radeon HD 5800 and I just lost my GUI for Linux (typing this in windows at the moment).

I've read about gallium3d being great drivers, but I can't find anything any where how to install these drivers or where to get them.

Can anyone help?

share|improve this question
up vote 2 down vote accepted

You can find articles and benchmarks of linux display drivers on Phoronix.

If you really want to use gallium3d drivers, open a terminal by pressing CTRL+ALT+T and follow these instructions (taken from here):

  1. Add ppa:oibaf/graphics-drivers Launchpad logo (Click here for instructions on using PPAs.) to your system:

    sudo add-apt-repository ppa:oibaf/graphics-drivers
    sudo apt-get update

  2. Install the driver:

    sudo apt-get install libg3dvl-mesa

  3. Restart.

You can revert to the default drivers by removing the PPA as follows:

  1. Install ppa-purge:

    sudo apt-get install ppa-purge

  2. Purge the PPA:

    sudo ppa-purge ppa:oibaf/graphics-drivers

share|improve this answer
did that, when I got to Step 2: Install the driver I get the following error: E: Ubable to locate package libg3dv1-mesa – Michaeljwjr Nov 16 '12 at 4:24
Never mind, It was an L not a 1. That... worked I think. As in it installed something but it doesn't appear to have actually changed anything. My System Settings still says Unknown for the driver. – Michaeljwjr Nov 16 '12 at 5:07
Can you post the terminal ouput for glxinfo | grep 'renderer string'? – mrcktz Nov 16 '12 at 14:02
The program 'glxinfo' is currently not installed. You can install it by typing: sudo apt-get install mesa-utils I ran the install, rebooting to see if that fixed it. – Michaeljwjr Nov 16 '12 at 18:05
Thank you @mrcktz Everything works and is installed properly :D – Michaeljwjr Nov 16 '12 at 18:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.