Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought this 2tb Segate GoFlex this last Black Friday and since then every 15 minutes or so the drive spins down, and then a little while later completely dismounts. Very annoying. From what I understand you could turn this off using the including Windows and Mac only software. This function and what controls it isn't proprietary, right? There has to be something that'll let me set it in Ubuntu... Anyone have any suggestions?

Also, I formatted it to EXT4. Hope I didn't screw myself up. :/

share|improve this question
add comment

1 Answer

You can dissable the powermanagement of your device with the following command (no powermanagement = no spindown - no standby for the harddrive)

hdparm -B 255 /dev/sdX

replace sdX with the name of your harddrive

This will only last till you restart your pc.

If you want it to be permanent: write the command in this file

/etc/rc.local 
share|improve this answer
    
I just tried. Gave me this: /dev/sdf1: setting Advanced Power Management level to disabled HDIO_DRIVE_CMD failed: Invalid exchange HDIO_DRIVE_CMD(identify) failed: Invalid exchange –  RPG Master Jan 16 '11 at 6:03
1  
@RPG /dev/sdf1 looks wrong - try /dev/sdf (the drive) rather than sdf1 (the partition). If the drive does not accept -B, try some of the other options; like -S0 (disable spindown) or -S251 (spindown after 5.5 hours). See the hdparm man page for the full list, for most drives at least some of the commands work. –  j-g-faustus Jan 16 '11 at 13:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.