Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Before close as duplicate please read my constraints:

  • I have no root
  • My box is a 12.04. virtual machine in some rack
  • I login from windows using Nomachine NX, it directly sends me to the desktop, no login on the ubuntu box, when I logout, the nx-connection is disconnected.

I assume that the classic desktop is installed by default. How can I check?

How can I configure my account to use the classic desktop? e.g. using settings-panel or gnome-config?

share|improve this question
    
Can you install software on this VM? –  user68186 Nov 15 '12 at 14:26
add comment

1 Answer

up vote 2 down vote accepted

With the NX client you can set which desktop (application) to run after the ssh connection has been established.

  1. Open the main NX Client and click the Configure button, you will find a dialog for setting up the connection.
  2. In the Desktop section choose "Unix" and "Custom". Then click the Settings button.
  3. In the top section of the Custom - Settings dialog you can now select to run any arbitrary command. That command could be any X application. I run xfce so I just enter the "startxfce4" command into the box.

Naturally you will be limited to what is installed, but if the Classic Desktop is installed you can put in the command to start it. If I remember correctly it is something like

gnome-session --session=gnome-classic

You could also just set up connections for each application you want. For example, you could put "emacs" as the command and have Emacs running as a separate window on your Windows desktop.

Hope this helps and is not too late.

share|improve this answer
    
this is very good! but it does not work yet. Funny thing is that I get many many "windows" each containing a part of the desktop: one for each panel, one for the desktop, one for the menu ... But the main idea should be ok. I will try to figure out ... –  Bastl Dec 18 '12 at 13:47
    
I had this problem too with the Gnome desktop at one point. I don't remember if I got it fixed before I switched to xfce, which does not do this. You could try playing with the Options - New virtual desktop settings. –  MatthewD Dec 18 '12 at 18:23
    
Yes that is the problem. I duplicated this again by setting the option to "Floating Window" in the Custom - Settings dialog. Fix it by changing the setting to "New virtual desktop". –  MatthewD Dec 18 '12 at 18:33
    
Hero of the day :-) –  Bastl Dec 20 '12 at 15:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.