Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I followed step-by-step from this site :

Installing Ubuntu inside Windows using VirtualBox


This is my system info:

System Information
-———————-
Time of this report: 11/14/2012, 22:40:29
Machine name: CHRISTOPHER-PC
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.110622-1506)
Language: English (Regional Setting: English)
System Manufacturer: System manufacturer
System Model: System Product Name
BIOS: BIOS Date: 02/05/10 19:13:52 Ver: 08.00.10
Processor: Intel® Core™ i5-2500K CPU @ 3.30GHz (4 CPUs), ~3.3GHz
Memory: 8192MB RAM
Available OS Memory: 8174MB RAM
Page File: 2227MB used, 14117MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 64bit Unicode
DxDiag Previously: Crashed in Direct3D (stage 2). Re-running DxDiag with “dontskip” command line parameter or choosing not to bypass information gathering when prompted might result in DxDiag successfully obtaining this information

I get the following VirtualBox Error: Failed to open a session for the virtual machine Ubuntu 64bit.

    VT-x features locked or unavailable in MSR. 
    (VERR_VMX_MSR_LOCKED_OR_DISABLED).

    Result Code: E_FAIL (0x80004005)
    Component: Console
    Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

I have no idea what's going on. I got Ubuntu up on running on my laptop, but I just got a desktop and I can't seem to get it working.

Downloaded ubuntu-12.04.1-desktop-i386 from Ubuntu 12.04.1 LTS (Precise Pangolin)

share|improve this question
    
you should try going into your bios settings and see if virtualization is enabled. Cause that's a virtualbox error message not ubuntu. And I think VT-x features are cpu virtualization features. But you can look it up in the virtualbox settings. –  Daniel Nov 15 '12 at 7:04
    
Yes. Got it working. Thanks –  zyeek Nov 15 '12 at 7:14
add comment

6 Answers 6

For optimal performance of Virtual Box we need to enable VT-x (on Intel systems) or AMD-V (for AMD systems) in our BIOS settings in case our CPU has this feature.

To use this virtualization technology we then can enable this in the system settings for a virtual machine from Virtual Box Manager (Settings -> System -> Acceleration).

By doing so we are even able to run a 64-bit guest on a 32-bit host.

The architecture of the virtual machine (32- vs. 64-bit) also needs to be defined in the machine's General settings. In your case when installing the -i386-version this would be 32-bit (for 64-bit use the -amd64-images).

See also the following question: amd64 virtual machine in virtualbox

share|improve this answer
add comment

On my [new] HP Envy Phoenix (h9-1420t) I was surprised to find this BIOS setting in:

Security -> System Security -> Virtualization Technology (VTx/VTd) > disabled

share|improve this answer
add comment

The Virtualbox error reported is related to VTx functionality in the host machine BIOS - check that VTx is enabled there (not in the guest machine virtual bios)

Important note: - in some buggy BIOSes, it may help to try setting it both on or off (it should really be enabled) if this does not work as expected - my HP workstation BIOS is buggy like this - the host BIOS displays it wrongly.

Once VTx is correctly enabled, it should be possible to use more than one virtual processor when running in a VTx enabled multicore host. It should also be possible to run 64bit guest machines on a 32 host, but again, only if VTx is enabled on the host.

share|improve this answer
add comment

Maybe you are using more than one CPU or processor in your virtual machine. Open it again and retry. Setting -> System -> Processor

share|improve this answer
add comment

I figured out that using the escape key and then pressing f10 key. The BIOS menu came.

share|improve this answer
add comment

You have to be an administrator to run Virtualbox. Right click and choose "Run as administrator"

share|improve this answer
1  
While this is about a windows host system, I doubt very much that running virtualbox as administrator is the sensible thing to do. –  guntbert Aug 16 '13 at 15:25
1  
@guntbert Agreed. Many Windows users run with administrative accounts all the time, but the risk is now somewhat mitigated by User Account Control. I've run VirtualBox and VMware in Windows 7 and 8, which have UAC (and I had it enabled in both). I have never had to use the "Run as administrator" option to virtualize a guest with either. Installing software requires acting as an administrator. Occcasionally on some systems configuring virtual hardware settings requires acting as an administrator. Actually running a VM does not. –  Eliah Kagan Aug 16 '13 at 15:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.