Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It seems like there's been such problems with external monitors for a while, but even if I updated everything I knew that could be upgraded, I still face the same problem.

I have an old laptop that its LCD panel is broken and I wanted to convert it into an HTPC with Xbmc on Ubuntu, as I would plug a monitor through its HDMI or VGA ports. However, when I tried to install Ubuntu 12.04 LTS or Ubuntu 12.10, at some point the shell would show something like

"ERROR Couldn't find PLL settings for mode!

I don't have any log about this error or whatever (I must admit that I'm quite new to GNU/Linux distros), but I somewhat succeeded to bypass the error by plugging the HDMI or the VGA cable when the GUI was loaded. Then, I can follow the procedures while the OS is installing, but then comes the reboot, and again, when one of the two display cables are plugged in, this message appears

[ 11.533760] [drm:i9xx_crtc_mode_set] ERROR Couldn't find PLL settings for mode!
[ 11.533771] [dr,: drm_crtc_helper_set_config] ERROR failed to set mode on [CRTC:4]
[ 11.548790] [drm:i9xx_crtc_mode_set] ERROR Couldn't find PLL settings for mode!
[ 11.548791] [dr,: drm_crtc_helper_set_config] ERROR failed to set mode on [CRTC:4]
[ 624.009224] [drm:i9xx_crtc_mode_set] ERROR Couldn't find PLL settings for mode!
[ 624.009228] [dr,: drm_crtc_helper_set_config] ERROR failed to set mode on [CRTC:4]

I tried to reboot with the cables unplugged so the GUI would load just like when installing, but, when the graphical interface appears, a system box says that the GUI couldn't load since there was a problem with graphic devices or whatever, and then offers me choices such as entering the console mode, running in safe graphics and 2 other that I can't recall, but the cursor is not visible and I can't make a choice with the tab or the enter keys.

I made a lot of googling before posting, tried many methods such as the nomodeset, upgrading and updating through apt-get. I know there's been problems with versions 10 and 11, but I read that such problems with Intel cards/chips were fixed with the 3.5 kernel version, which did not change anything for my part...

Some specs: Brand and model : Gateway NV58 CPU : Intel Core 2 Duo @~2.10 T6500 RAM : 4 Gb GPU : Intel Graphic Family Express, though I can't recall the exact version... Will make further research if needed.

Thanks for your precious help, and sorry if anything's unclear, english is not my primary language ^^'

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.