Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got an HTPC that I built myself, with a Asus P5G41T-M Motherboard. It's got an on-board HDMI port, and I've been using that with no problems. I started out with Mythbuntu ( an older version ), and recently updated to 12.04.1 LTS without any issues.

I've been thinking about trying out XBMC for a while, and I decided to give it a go. Unfortunately, I seem to be running into quite a few issues.

I got XBMC installed from the repos without any issues, but when I try to run it from a console, a box pops up with the following:

XBMC needs hardware accelerated OpenGL rendering. Install an appropriate graphics driver.

Please consule XBMC Wiki for supported hardware http://wiki.xbmc.org/?title=Supported_hardware

In the console, it prints out the following:

X Error of failed request: BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  136 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  12

When I run vainfo, I get this:

libva: VA-API version 0.32.0
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA-API version: 0.32 (libva 1.0.15)
vainfo: Driver version: Intel i965 driver - 1.0.15
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD

The file /usr/lib/x86_64-linux-gnu/dri/i964_drv_video.so exists:

# ls -l /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so 
-rw-r--r-- 1 root root 628728 Mar 29  2012 /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so

And in /var/log/Xorg.0.log the following error pops up:

GLX error: Can not get required symbols.

I'm not really sure where to go from here. I've tried searching all over for how to fix this problem. I've done "apt-get --reinstall xserver-xorg" ( as well as a few other video driver packages ) a few times, and no change.

Any help in getting this issue sorted out would be awesome.

share|improve this question
add comment

3 Answers 3

I had similiar problems and I googled: Bumblebee Ubuntu/Linux for Nvidia, then I downloaded and installed according to this Bumblebee project and XBMC started to work. It looks like that drivers from Ubuntu for Nvidia graphics seem to be incomplete. Greets Arek

share|improve this answer
1  
My motherboard doesn't use an NVidia GPU, it's got an on-board Intel GPU. This solution doesn't work for me. –  Sean Hagen Nov 23 '12 at 23:56
add comment

When I needed to get my onboard Intel Corporation Mobile 945GM/GMS, 943/940GML Express to work, I did the following:

sudo apt-get purge nvidia*
sudo apt-get install --reinstall xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg
sudo update-alternatives --remove gl_conf /usr/lib/nvidia-current/ld.so.conf

This will remove any remnants of possible proprietary Nvidia driver stuff and install the necessary Intel drivers and the necessary OpenGL support.

share|improve this answer
add comment

Not a fix but a suggestion, have you thought of installing XBMCbuntu as the main OS? I'm using it on a number of systems and it runs quite well, particularly when you share the media database amongst various hosts.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.