Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get the following error. I think it is a bug. Is there a workaround? There is mismatch between the 32 and 64 bit version of this package.

apt-get install libcairo2:i386

Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: libatk-wrapper-java-jni : Depends: libgtk2.0-0 (>= 2.12.0) but it is not going to be installed Depends: libatk-wrapper-java (>= 0.30.4-0ubuntu4) but it is not going to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

share|improve this question

1 Answer 1

Drop the i386 part just libcairo2

sudo apt-get install libcairo2
share|improve this answer
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  Evandro Silva Nov 15 '12 at 0:54
    
This will install the 64 bit version, which is already installed. (this is why I have the conflict, the 32 and the 64 bit versions have different version number) I need the 32 bit version. Otherwise I will not be able to install steam. I have similar issues when trying to install wine. –  user63726 Nov 15 '12 at 5:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.