Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set permissions for folders on USB drives that I've mounted with Nautilus, but when I change the permission, it just changes right back again. No error message or any other explanation. I've tried "Open as administrator" and it still doesn't work. How do I set the permissions so that they can be accessed as shared folders on the network?

share|improve this question

The problem is that your USB stick is probably using FAT(16/32) or NTFS as file system which doesn't support permissions. That's why they change back after edit in nautilus. If you want to use permissions with USB sticks/drives, you'll need to format it to any EXT formats (use either 3 or 4) using gparted (install with synaptic).

share|improve this answer
should add that using EXT file systems can not be read from windows without additional software (like ) – digitaljail Jan 15 '11 at 20:41
That's what samba is made for: mounting and sharing FAT32 or NTFS drives. – Takkat Jan 15 '11 at 23:38
@digitaljail: I can access shares of EXT folders from Windows. It doesn't need any additional software. – endolith Jan 16 '11 at 0:59
@endolith as Share trough Samba, you right, but if you connect the USB drive to a Windows system for some reason, you need additional software in order to access data on the usb drive. – digitaljail Jan 16 '11 at 14:18
and NTFS supports permissions – endolith Mar 3 '11 at 6:08

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.