Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.10 on a new PC with an Nvidia GTX 560 graphics card, but after installing the Nvidia proprietary drivers (either -current or -current-updates), Unity won't start. When trying to start it manually I get the message "extension GLX missing".

I've searched around and found results like this question which point out it's a problem with Nvidia Optimus laptops. However, I don't have this problem on a laptop, but on a desktop PC.

Update: It seems that Optimus is now available for desktops under the name 'Synergy'. Note that if that's the case here, I'm just looking for a way to get my main GPU working in Ubuntu, and having the switching capability is a low priority.


lshw output for the graphics card:

 *-display
                description: VGA compatible controller
                product: GF114 [GeForce GTX 560 SE]
                vendor: NVIDIA Corporation
                physical id: 0
                bus info: pci@0000:01:00.0
                version: a1
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
                configuration: driver=nouveau latency=0
                resources: irq:16 memory:f4000000-f5ffffff memory:e0000000-e7ffffff memory:e8000000-ebffffff ioport:e000(size=128) memory:f6000000-f607ffff

and CPU:

 *-cpu
          description: CPU
          product: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
          vendor: Intel Corp.
          physical id: 40
          bus info: cpu@0
          version: Intel(R) Core(TM) i5-3570K CPU @ 3.40GHz
          slot: SOCKET 0
          size: 1600MHz
          capacity: 3800MHz
          width: 64 bits
          clock: 100MHz
          capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms cpufreq
          configuration: cores=4 enabledcores=4 threads=4
share|improve this question
    
Just out of curiosity...have you gone into your BIOS to make sure that your system doesn't have Optimus (for whatever stupid reason)? –  Shauna Nov 14 '12 at 21:52
    
I wouldn't know how to see that, but will look into it. I did see in the BIOS that the graphics device is set to PEG (PCI Express Graphics), the other option being IGD (Integrated Graphics Device). –  Bart van Heukelom Nov 14 '12 at 22:00
    
@Shauna I've looked in the BIOS but don't find any switch for Optimus/Synergy (the name for desktops) –  Bart van Heukelom Nov 14 '12 at 22:24
add comment

1 Answer 1

Perhaps the option will be unlocked with a bios update, or maybe there is a bios update for the graphic card itself (normally called Vbios)?

It would be necessary to get the bios from the manufacturer it self, rather than nvidia, for instance here is a Vbios from asus for an nvidia 560 (I don't know if is the right one, you MUST be sure you have the right one before installing any BIOS, manufacturer model and all)

support

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.