Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm struggling now for more than two days with NVIDIA drivers. First, I didn't realize what the problem was, I just noticed my computer became slow (Intel i5 2500K @ 4.3GHz, 8GB 1600Mhz RAM).

As you probably know, installing an NVIDIA proprietary driver on 12.10 isn't an easy thing, even the "tested" driver in Software Sources doesn't work, after restart there's no GUI in Unity. It is because linux-headers-xxx-generic is missing. You have to install it manually and then install the driver.

After that, you restart, everything seems to be fine. As I thought yesterday when I used the newer, 304.64 driver from ubuntu-x ppa:

I set up everything, the only missing thing is that the Nvidia settings aren't saved. "Well, there's this button here saying Save to X Configuration file, let's press it", so I pressed it, saved to the /etc/X11/xorg.conf as it suggested me in the input field.

Restart. Slow computer. Confused user.

Firing up terminal, top shows that Xorg eats my CPU. Looking at htop says that it's /usr/bin/X : 0 -core -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch. It's using the CPU almost constantly and ~50% every time.

After some time spent searching on Google, the best "help" I could find was that X doesn't like if you change its settings.

Okay then, I reinstalled Ubuntu, deleting the previous. Now, I installed the "tested", 304.43 driver, but the problem is present. The only difference is that I had to use nvidia-xconfig, because there was no xorg.conf and only after that was I brave enough to save the X configuration to file from within the Nvidia settings.

The only thing I know is that changing (or even creating?) xorg.conf file makes Xorg CPU-hungry and the problem is present with 304.43, 304.64 and the 310.xx beta driver and even in Linux Mint.

Some other info I think could be important:

  • Ubuntu 12.10 64-bit with Unity
  • ASUS GTX 560 DirectCU II OC
  • using two monitors, one with DVI one with HDMI (but it doesn't seem to change anything)

If anyone could help me how to resolve the problem I'd appreciate it, even a little help where to start would be good.

Thanks in advance.

share|improve this question
    
I don't have any solution to your problem, but I have been experiencing exactly the same issue. I tried different nvidia driver versions and it doesn't help. (Note that I also get some slow performance with Nouveau.) It is strange that very few people report this bug. Sadly, I cannot enable/disable ACPI in my BIOS, so I am still having the issue. –  user146665 Apr 4 '13 at 2:41
add comment

1 Answer 1

I had a similar problem, which I able to solve by enabling ACPI in my BIOS. It had been disabled, which had apparently caused the problem.

I tested to see if there was still a performance problem after changing the BIOS settings, and it appears to be running very well. Blender runs at 60 fps! On a freshly installed system the nvidia-current-update driver package, the process listed as /usr/bin/X : 0 -core -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch only uses 1% of the CPU.

Detailed machine/software specs.

So, try making sure ACPI is enabled in your BIOS settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.