Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed software to our administration machine. The problem is that i cannot start the software or uninstall it, as it is not in any directory on the machine. I tried to install it at /pack/CST/... but it is not there and a locate on CST or cst returns nothing. The software is installed from a DVD and not a repository.

I've tried to reboot the machine, as i thought i might had something to do with the software being loaded in some sort of tmpfs but that didn't help.

I've looked through the entire /etc to check for any relations to the software, but unsuccessfully.

I'm out of ideas, to what can cause this problem, anyone got any ideas??

EDIT: I downloaded the iso wich i mounted with:

sudo mount -o loop /path/to/iso.iso /path/to/mountpoint
sudo /path/to/mountpoint/install.sh

Ran the install GUI via an X-session. I choose to install the software in /pack/CST/... but when it exited it said that the software had been installed to /tmp/... There was nothing in tmp, so i decided to reboot the machine and did a full find to see if there was anything left of the software, removed what looked like it could be related. It had placed a script in all the /etc/rs* folder which I removed with:

sudo update-rc.d -f scriptname -r

I rebooted the machine again, just to be sure. When i run the installer again, it tells me that the software is installed in NULL and i have to remove before installing it.

/pack/ is a mountpoint for /q/system/pack

What i expected was that the software would be installed in /pack/CST, but it seems to be lock in the system, but I am unable to locate where.

share|improve this question
3  
how did you install it? please describe the exact steps. (I doubt you installed it to my administration machine ;) ). How did you try to install it to "/q/CST"? What is "/q/CST" (is it mounted, is it a special volume, what is there now). AKA: please provide more information, especially the actual steps you took, what you expected, why you expect that, what is now different from what you expected, etc. –  Nanne Nov 14 '12 at 12:33
    
There you go. I've edited the OP. Ohh, it is on your machine, I'm that good :-P Hope this is enough information. –  ChosSimbaOne Nov 14 '12 at 12:58

1 Answer 1

up vote 0 down vote accepted

The problem appeared to be known by the software developer. After gaining access to their support forum, i found this thread. https://www.cst.com/Content/Support/Forums/ShowThread.aspx?threadId=285

The problem is that the installer stores a hidden file ".com.zerog.registry.xml" in /var/.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.