Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried many different ways to get my printer to work:

  • I tried using a generic Model for the printer, since it is not supported by ubuntu yet.
  • I tried using a model that is close to the one I have.
  • I tried downloading the official .rpm package and repack it as a .deb package and install it (Not sure if that actually worked).
  • I tried to run the script provided here and that seems to have worked for others but not for me.

What I have now is this: My printer is recognized with the right name, Make and Model. When I send data to the printer it changes from 'Idle' to 'Processing' and then just flags the job as done, even though it didn't do a thing.

I have no idea how to repair the mess I created. If anyone has an idea, I would really appreciate it.

share|improve this question

1 Answer 1

I have had exactly the same problems as you describe (on a 64-bit Ubuntu) but with the LBP7200Cdn printer. Today I (coincidentally) found a new(er) version of the Canon CAPT drivers (2.56), including a precompiled 64-bit debian archive here.

After trying this version, with exactly the same (official Ubuntu) steps as I tried many times before, it worked instantly! So maybe this will solve your (similar) problems as well!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.