Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an old PowerBook G4 that worked (more or less) fine with a previous installation of Ubuntu Desktop 12.04. A few days ago I decided to install Ubuntu Server instead, and got a copy of Ubuntu Server 12.10. The installation seemed to complete successfully, but now, whenever I try to boot the system, it simply halts at some point after I unlock the hard disk. There is a lot of text on the screen (which is normal for me during a boot, except now it's mostly errors and debug information), the last of which is this:

[   26.338228] Fixing recursive fault but reboot is needed!

Pressing control command power to force a reboot yields exactly the same results.

A search for the error message turned up many temporary solutions involving kernel parameters, but none of them have worked for me. I don't think I can remove the default set of parameters (which I think is quiet splash), but I can pass additional parameters on boot. I've tried booting on AC and battery power, as well as using these combinations of kernel parameters while on battery power:

acpi=enable pci=noacpi pci=assign-busse acpi=ht
acpi=off
nomodeset
nomodeset acpi=off
acpi=off nomodeset xforcevesa

Why am I getting this error and how can I fix it?

share|improve this question
    
This is by no means a solution, but a daily build of the previous version of Ubuntu—12.04 “Precise Pangolin”—installed and worked fine for me. –  Blacklight Shining Nov 15 '12 at 6:06
add comment

1 Answer 1

up vote 0 down vote accepted

I have a 15" PowerBook G4 and I was able to install Lubuntu 12.10 from a USB stick when I entered these yaboot paramaters:

live snd-powermac.blacklist=yes video=raedonfb:1024x768-32

I found that stuff on the PowerPCKnownIssues page at the Ubuntu site.

share|improve this answer
    
I don't have another PowerPC machine to test this on, and I'd rather not wipe the one that currently works. Sorry. :( –  Blacklight Shining Aug 1 '13 at 15:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.