Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just recently switched my system over to Ubuntu 12.10, and decided on Cinnamon as my environment-- it all worked fine, at first. But I was poorly educated and started using Compiz and Emerald along with it--Setting both as replacements in startup processes. I now know, that's a big, big mistake. Now when loading Cinnamon, I am greeted to my background image, and only that. My only options seem to be to open a terminal.

I was advised to attempt

muffin --replace

and

mutter --replace

Neither to any avail, the terminal closes, and I cannot load another one unless I completely reload.

I went back to Unity, purged and autoremoved Cinnamon, emerald, and compizconfig, and attempted to reinstall Cinnamon, thinking that would solve the problem--no, it came back just as broken as before.

So, I reinstalled ubuntu, then cinnamon---still broken.

I'm assuming I must find a way to remove the replace commands-- but as I have no menu, I'm not positive I can do that.

Is there any way I can access the startup processes via terminal? I'd think though, if I completely removed Cinnamon, all configurations would be gone too, so, it's just not making much sense. Is there some kind of reset I could possibly do? I've been browsing forums and questions here, all leading to things I'd already done, so, it can't hurt to ask for myself. I apologize if you would rather I have posted this over at mint.

Next time, I will definitely check compatibility instead of assuming something just has to work.

Any help is greatly appreciated, thanks!

share|improve this question
    
Cinnamon uses muffin, but Unity uses mutter. –  Enkouyami Feb 19 at 20:09
add comment

2 Answers

Access the settings and startup processes for Cinnamon via Unity, and, after quickly removing aforementioned processes.

It seems although it didn't allow me to do it before, I was now allowed to access the settings and startup processes for Cinnamon via Unity, and, after quickly removing aforementioned processes- I'm up and running again.

Source: an edit to the author's question.

share|improve this answer
add comment

When you at the stage where you can see your background and nothing else, you use the keyboard shortcut, Ctrl+Alt+T, to open a terminal.

If you can't access a terminal that way, you could access one of the tty terminals by holding down the keys Ctrl, Alt, and F1 (F1-6 will work). Next, attempt to login. When you're logged-in, you're free to execute commands in that terminal.

When you have a terminal open and ready to use, enter in export DISPLAY=:0.0 so that commands executed can use your graphical display.

Next enter in cinnamon-session-properties to open the Startup Applications Preferences on display 0.0.

If you're in a tty terminal and want to go back to your regular display (0.0), hold down Ctrl, Alt, and F8.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.