Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have problem in using POINT GREY FIREFLY MV FMVU-13S2C digital camera to work on Ubuntu 11.04.

This is the version of ubuntu.

adrian@ubuntu:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 11.04
Release:    11.04
Codename:   natty

As far as I know, POINT GREY FIREFLY MV FMVU-13S2C uses IEEE1394 interface to transfer data with computer. So I downloaded the Coriander – the linux GUI for IEEE1394/Firewire cameras.

However, when I plugged in the camera and launched the coriander, this error appears:

Warning: could not find a Digital Camera on the bus.
Please check that:
-the cables are properly set
-the devices on the bus are properly powered
-your camera is compliant with the Digital Camera specs (see http://www.1394ta.org).

Then I run the command lsusb:

adrian@ubuntu:~$ lsusb
Bus 003 Device 002: ID 1e10:2002 Point Grey Research, Inc. 
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 17ef:1003 Lenovo Integrated Smart Card Reader
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 007: ID 04f2:b217 Chicony Electronics Co., Ltd 
Bus 001 Device 006: ID 0a5c:217f Broadcom Corp. Bluetooth Controller
Bus 001 Device 005: ID 147e:2016 Upek Biometric Touchchip/Touchstrip Fingerprint Sensor
Bus 001 Device 004: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 003: ID 0765:5001 X-Rite, Inc. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Apparently, the first output is the camera.

Then I guess maybe I need to configure udev to work with camera. So I run

sudo gedit /etc/udev/rules.d/10-pointgrey.rules 

and type in the following text:

BUS=="usb", SYSFS{idVendor}=="1e10", SYSFS{idProduct}=="2002", GROUP="plugdev"

Then I restart the udev by sudo restart udev and restart coriander again. But the same error still appears.

Then I opened the official website of the POINT GREY and downloaded the FlyCapture2 software. Surprisingly, This software is able to recognize the camera. Why coriander cannot recognize camera? camera1394 ros node also cannot recognize camera.

Can any help me to solve this problem? Thanks in advance.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.