Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Having an issue with sound at the moment. I am trying to configure my 5.1 surround sound but it will only work on the Front left and Front right speakers. On the back of my motherboard I have 3x3.5mm jacks which I have connected the speakers to although these are not the right ports.

I want to "assign" the three ports on the back to each output (Sub and centre, Left and right, and rear left and right) although I'm not sure how to do this. My audio is ALC889 from Realtek and am using Ubuntu 12.04 with all updates installed.

share|improve this question
    
Did you select a correct channel mode for your card? Install pavucontrol, run it, and see the settings in the "Configuration" tab. The commandline way is running alsamixer in a terminal, select the right sound card and change the channel mode. Similar to most right mixer setting in this screenshot. –  gertvdijk Nov 16 '12 at 21:13

2 Answers 2

Did you checked SurroundSound on Ubuntu documentation? This(The Simple Way to Get 5.1 Surround Sound Audio Working in Ubuntu) article might also help you.

share|improve this answer
    
Sorry it seems you have misunderstood my question,I'm wanting to assign ports on my motherboard as I do in realtek audio manager in windows,when you plug a device in on windows,realtek audio manager will ask what you plugged in (eg plug in centre/sub to line in) and I can assign what to do with that port,I would like to do this but in ubuntu –  user107829 Nov 21 '12 at 20:34

First, you should define in ALSA that you have 6 channels. You can refer to this post. Basically, you launch alsamixer and you define (for the right soundcard) the number of channels to 6. Then you store the configuration in order to be reloaded on reboot:

sudo alsactl store

Then pulseaudio should be configure (pulse is the sound layer that will be used by apps and talks directly to ALSA.). You should define the number of channels in /etc/pulse/daemon.conf, like said in this documentation:

default-sample-channels = 6

Also, to enable the remixing of low frequencies in your subwoofer, you should activate this in your sound card by editing the same file /etc/pulse/daemon.conf:

enable-lfe-remixing = yes

Then, you maybe need to reboot, or kill and relaunch pulseaudio:

pulseaudio -k
pulseaudio -D

Then, pavucontrol may help you, as replied in this question. In the configuration tab, you should see different profiles for your sound card, for example "Suround analogiq 4.1" that means that you want to use 4 channels and 1 subwoofer.

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.