Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After a fresh install of Ubuntu 12.10, my screen still goes off after about ten minutes. I've been to the Brightness and Lock control panel. The Turn screen off when inactive for: setting is set to Never.

I've been through the dconf editor searching for power, screen, and idle changing parameters. This doesn't seem to have any effect on the display timeout.

Here's one more interesting thing, the screen doesn't go off, it just goes black. The back lighting is still on, and all the pixels are black.

When it goes black, it does a very pleasant quick dim to black.
Similarly, it quickly un-dim's after a key press, mouse movement, or mouse click.

share|improve this question

5 Answers 5

There are multiple different layers, that influence the behavior of the monitor. To completely disable any suspension of the monitor you need to disable it in every of those layers:

1. layer: virtual consoles

Sets the interval of inactivity, in minutes, after which the screen will be automatically blanked:

setterm -blank 0

Sets the VESA powerdown interval in minutes:

setterm -powerdown 0 

2. layer: X

Turn the screen saver function off. The s option lets you set the screen saver parameters.

xset s off

Disable DPMS if enabled:

xset -dpms

To find out which values are set type xset -q in a terminal. A part of the output should look like this:

Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0

and this:

DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Disabled

3. layer: Last but not least; the application layer (XScreenSaver)

xscreensaver-demo

Choose Disable Screen Saver:

xscreensaver

And deactivate screensaver in System Settings -> Brightness & Lock (depends on your desktop environment):

Turn screen of when inactive for: Never

Brightness & Lock

share|improve this answer
3  
for me, the devil was dpms. –  sazary Feb 19 at 6:33

I just ran sudo xset s off from a terminal and it may be fixed.

share|improve this answer
2  
@Dusty, dont keep us in suspense. Maybe fixed or is fixed? –  Stephen Myall Nov 14 '12 at 14:39
    
I fixed this by xset s 0 0 - not sure if this is equivalent. –  morgoth Nov 25 '12 at 15:55
    
This suggestion did work for me, but I also had to uncheck the 'Dim screen to save power' checkbox in the 'Brightness and lock' settings. –  Zoltán Jan 12 '13 at 20:57
1  
... err which suggestion worked for you Zoltan? xset s off or xset s 0 0... This is a really confusing question/answer page. –  Cory Gross Apr 16 '13 at 1:32
    
This one answer (i.e. "sudo xset s off") worked for me. I had also previously uninstalled gnome-screensaver, which didn't change a thing. (so I'm not sure whether one needs to do both things but I don't think so). –  matteo Oct 25 '13 at 14:56

The answer provided by chaos is very informative. However, even after following those instructions, I still had this problem intermittently. There is some sort of background process or settings manager that keeps resetting the screensaver, no matter what I do.

I've found a brute-force solution. Just add a line to your crontab to turn off DPMS and the screensaver every single minute. Ugly, but effective.

Type this at the terminal

crontab -e

And then add the following lines at the bottom of the file

* * * * * DISPLAY=:0.0 xset -dpms
* * * * * DISPLAY=:0.0 xset s off

You can also comment these lines out by prepending a '#' when you want to re-enable the screensaver.

share|improve this answer

In Ubuntu 12.10, If you have KDE as the windowing manager:

Disable monitor dimming and energy saving tool:

  1. Click System Settings.
  2. In the "Hardware" tab choose "Power Management"
  3. Choose "Energy saving settings"

there are two checkboxes: Dim Display and Screen Energy Saving. Make sure those are unchecked.

In Ubuntu 12.10, If you are using the default unity windowing manager:

  1. Click System Settings.
  2. In the "Hardware" tab choose "Power"
  3. Click the link: "Brightness settings"
  4. There is a dropdown called: "Turn screen off when inactive for"

Set the dropdown to 'Never'.

share|improve this answer

There is a checkbox in "System Settings" -> "Brightness And Lock" screen whose label is "Dim screen to save power". You must uncheck it.

share|improve this answer
    
There isn't such option at my ubuntu 12.10 :/ –  Chris Nov 24 '12 at 21:19
2  
It still goes black, exactly as described in question - I'm on Ubuntu 12.10 and Gnome 3 (it worked fine on Unity) –  morgoth Nov 25 '12 at 11:45
    
You should apply this advice in conjunction with the top rated answer, i.e. execute sudo xset s off. –  Zoltán Jan 12 '13 at 21:43
    
That label is not in Ubuntu 14.04 either... –  Peter Mortensen Nov 22 at 18:40

protected by Community Dec 16 '12 at 0:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.