Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get all the time notifications in the upper right corner and as a tray icon for all kind of actions, especially downloads.

What app is that in Lubuntu? (it is not notify-isd)

Is it possible to set what notifications to see? If not, how to remove this completely?

enter image description here

enter image description here

Update edit: Removing notification-demon (that being it seems the culprit, as an answer suggests) involves removing some important applications:

enter image description here

Lubuntu-desktop is a metapackage I guess. But what about removing deluge and update-notifier?

Can I add these back without getting back the notifier?? I do not want in any case to remove these two.

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

I'm pretty sure that whether notifications are sent to the notifier daemon is on a program by program basis, and you would have to change that in your browser's settings (if possible). I am not 100% sure on this though. At any rate, to just remove notifications altogether:

sudo apt-get remove notification-daemon

You can also replace Lubuntu's notification system with XFCE's, which won't queue up your notifications, like the default one does. To do that:

sudo apt-get install xfce4-notifyd
sudo apt-get remove notification-daemon

When doing it this way, it shouldn't ask to remove all those extra packages, as there will still be a notification system in place. I think it will still say it is uninstalling lubuntu-desktop, but that is because it is a meta package, meaning a package of packages. It won't remove your desktop. :-)

To change the settings for XFCE's notification system (timeouts, position, color), run this:

xfce4-notifyd-config
share|improve this answer
    
this has the following problem: too many applications are to be removed. see updated question –  cipricus Nov 13 '12 at 16:22
1  
I updated my answer with a workaround. –  reverendj1 Nov 13 '12 at 16:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.