Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I reinstalled Ubuntu 12.10. It was not clean reinstall, since I wanted to save my personal files. However, since then, apport message keeps popping out about packages that failed to install, and cannot be installed for some reason.

I tried to look on other forums, but did not find any answers to this problem.

Just today I realized, I cannot even install some programs (such as VLC,..) from Software Center.

How can I get rid of them and reinstall them, so the system works fine again?

It is saying that it will be installed, but nothing happens

vlc: Depends: vlc-nox (= 2.0.4-0ubuntu1) ale 2.0.4-0ubuntu1 se bude instalovat
     Depends: libavcodec-extra-53 (>= 6:0.8.3) ale 6:0.8.3.6ubuntu1 se bude instalovat
     Depends: libavutil-extra-51 (>= 6:0.8.3) ale 6:0.8.3.6ubuntu1 se bude instalovat
     Depends: libc6 (>= 2.15) ale 2.15-0ubuntu20 se bude instalovat
     Depends: libfreetype6 (>= 2.2.1) ale 2.4.10-0ubuntu1 se bude instalovat
     Depends: libgcc1 (>= 1:4.1.1) ale 1:4.7.2-2ubuntu1 se bude instalovat
     Depends: libqtcore4 (>= 4:4.8.0) ale 4:4.8.3+dfsg-0ubuntu3 se bude instalovat
     Depends: libqtgui4 (>= 4:4.7.0~beta1) ale 4:4.8.3+dfsg-0ubuntu3 se bude instalovat
     Depends: libstdc++6 (>= 4.6) ale 4.7.2-2ubuntu1 se bude instalovat
     Depends: libva-x11-1 (> 1.0.15~) ale nebude se instalovat
     Depends: libxcb-composite0 ale nebude se instalovat
     Depends: libxcb-randr0 (>= 1.1) ale nebude se instalovat
     Depends: libxcb-xv0 (>= 1.2) ale nebude se instalovat
     Depends: zlib1g (>= 1:1.2.3.3) ale 1:1.2.7.dfsg-13 

Does anybody knows solution to this? Thank you

share|improve this question

1 Answer 1

Try using the following commands (one at a time) in a terminal :

sudo dpkg --configure -a  
sudo apt-get install -f
share|improve this answer
    
The first one does not do anything and did not found anything to install, update...the message says: Package dependencies could not be resolved –  user99209 Nov 13 '12 at 18:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.