Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I deleted some large files from nautilus launched as sudo. They still show in /home/.Trash-0/files/<foldername> when I type sudo sh -c "du -h /home | grep -P '[0-9]G\t'" but when I type sudo rm /home/.Trash-0/files/* I get the message:

rm: cannot remove `/home/.Trash-0/files/*': No such file or directory

I was able to delete individual files with their exact file names in place of *, but when I used *, it gave the error message as above. I do not want to have to delete them all individually if I can help it.

share|improve this question

3 Answers 3

[Taken from Thread: I can't empty the trash as a user]

(Solution posted works in Ubuntu 13.10.)

The Trash folder is a hidden folder(the folders name begins with a period) in your home directory. You can press Ctrl+H in nautilus or select Show Hidden Folder from the View menu to list the hidden folders.

You can open nautilus in the .Trash folder:

gksu nautilus ~/.Trash

in Hardy Heron the Trash is in ~/.local/share/Trash/files/

gksu nautilus ~/.local/share/Trash/files/

Select the items you want to delete in the folder.

OR

You can delete the content of the folder from the terminal:

sudo rm -fr ~/.Trash/*

Hardy Heron:

sudo rm -fr ~/.local/share/Trash/files/*

share|improve this answer

Fixed it now by:

sudo -i to get into the root account, and then cd to /home/.Trash-0/info. Then rm -rf *. Then cd ../files/. Then rm -rf * again. Appears to have worked.

share|improve this answer
    
Directory doesn't exist –  KI4JGT Nov 27 '13 at 11:14

Do gksu nautilus to launch nautilus with root permissions. After that, go to the files you need to delete. Right click on them and change the permissions so that all users have access to edit and delete them. After that, you can just delete them as you regularly would without root permissions.

share|improve this answer
    
Running Nautilus with plain sudo is not recommended. –  Seth Oct 7 at 22:34
    
I guess so but it works for me. –  JohnDoe Oct 7 at 22:36
1  
Oh it works.. sorta. It causes problems later. See: askubuntu.com/questions/11760/… –  Seth Oct 7 at 22:39
    
Well ok thank you I will change it to gksu. –  JohnDoe Oct 7 at 22:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.