Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was just goofing around in a vm to test what would happen if I purgen unity:

sudo apt-get remove --purge unity*

I found that I get an startup error, but when I proceed, I got this awesome login screen: all sexy It has an sexy effect and is just the gnome style my whole pc has got.

So can any one please tell me how I change the default login screen program without having to bother clicking "fix this error" on every boot?

Thanks in advance.

[EDIT]:

I have been able to change it(my own answer), but now I see the old purple background for a second when I logged in, and that background is only used in the old greeter screen. How do I change it(or where are those backgrounds located)?

share|improve this question
    
What is the error? –  Frantique Nov 13 '12 at 10:51
    
uhhh, lemme crash my vm again, 2 sec. But it is in no way a addition to my question. –  Dr_Bunsen Nov 13 '12 at 10:53

3 Answers 3

up vote 2 down vote accepted
sudo dpkg-reconfigure lightdm

I selected gdm, and now I have the login screen I desire.(This replaces lightdm with gdm)

Thanks for the other suggestions, I found that this was the only one to work, since gnome has it's own desktop manager(gdm).

share|improve this answer

Boot in recovery mode, select root shell and issue: dpkg-reconfigure -phigh xserver-xorg. The error is related to misconfigured xorg. Have you installed the virtualbox extension pack? If not, do it!

share|improve this answer
    
thanks, but I dont mind the error, but the login screen it revealed, how do I install that? thats my question. –  Dr_Bunsen Nov 13 '12 at 13:01
    
Get rid of error, and you will have the login screen. –  Frantique Nov 13 '12 at 13:04
    
well surely there would be a nicer way to change the logon screen, I mean, we can edit anything here, why should I have to break 50% of my system to change a silly logon screen? –  Dr_Bunsen Nov 13 '12 at 13:11

If you are using lightdm as display manager, you can change the greeter in /etc/lightdm/lightdm.conf.

For example to use lightdm-gtk-greeter (=xfce greater):

#greeter-session=unity-greeter
greeter-session=lightdm-gtk-greeter

# Other options:

# to change unity to xfce session on default:
#user-session=ubuntu
user-session=xfce
# or to xubuntu:
#user-session=xubuntu

# hide users
greeter-hide-users=true

# disable guest login
allow-guest=false

As you can see there are more customization options to hide users or to select the default session for example. I don't know the name of the login screen on your picture so I used the one I use on my machine but I guess you can find it out on your virtual machine and use it on your main if that is what you want to do.

share|improve this answer
    
Thanks, I will try this. –  Dr_Bunsen Nov 13 '12 at 13:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.