Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

BACKGROUND INFO: My hard drive recently failed and I haven't had the money/time to replace it. I tried a Live version of Ubuntu from a thumb drive and decided I liked it, so in the meantime I've decided to install 12.04 to a SD card and run it from there. I've spent about a week working on drivers, customization, and basic exploration, scouring Google for answers and learning from my mistakes, but a couple of items I could not find any good information on so I've decided to suck it up and ask.

PROBLEM(s): I started out installing to a microSD card (within an adapter) simply because I had one, but it was running quite slow. I purchased an Ultra SDHC card (16 GB) because it boasted a 30 MB/s read speed and installed Ubuntu 12.04 to it. This sped things up a bit. However, I'm still getting only ~20 Mb/s read speed maximum, and 11 Mb/s read speed on average. Is this typical for these media readers? I've tried benchmarking the drive on Ubuntu 12.10 as well, and also while running the OS from a LiveUSB drive (so the card reader wasn't in use during testing). These all had similar results. Is this typical of these card readers or the cards themselves? I have no way of testing the drive in Windows or in any other setting. Could this be a driver issue?

Also, my computer seems to dislike booting from the card reader. It will boot from it just fine (I'm running Ubuntu from it right now), but no matter how many times I update the BIOS it seems to forget about the card reader altogether, so I have to always boot using the boot options menu. About 1/4 of the time, the reader won't even show up, though a quick restart and return to boot options always resolves the issue. This is regardless of the fact that there is literally nothing else to boot from.

Lastly, the computer will not fully wake up from sleep. You can hear it start up, but the screen remains blank no matter how long I wait. This happens every time I allow to go into sleep mode (as opposed to only some of the time). It has never awoken from sleep.

Below, I hope, is any information you might need:

Per the Gateway support page for my laptop, the card reader is an RTS5117. It is not listed on Realtek's website under products (though they do list an RTS5116).

Running lsusb in the terminal, the device identifies as:

Bus 001 Device 004: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader

Disk utility displays the drive with the following info: "Generic Multicard Reader", Firmware Version: 1.0, Device: /dev/sda , Connection: USB at 480.0 Mb/s

The laptop is a Gateway T-1625. Here are the motherboard specifications, where it shows the card reader model. I would provide more links but I've hit the link limit.

The card I'm using is the 16GB SanDisk Ultra SDHC Class 10 Memory card. On the website it is item # SDSDU-016G. (I've hit the link limit or I would provide one.)

This is the Windows Vista driver recommended by Gateway, in case that can provide any information.

I'm aware that I grouped a few problems into one thread, but I thought that they may be related. If they are not I can update the post accordingly. My main problem is the read/write speed of the card reader. The booting is only an annoyance and I can disable sleep if needed.

Thanks for your help. If you need any additional information just ask and I will update my post.

share|improve this question

1 Answer 1

I think this is about what I would expect. The class 10 does mention the number 30, but keep in mind that this is sales-speak: it means "Up to 30MB/s read speed".

If you look at the specs of what "class 10" means1 you get:

Class 10 is more than or equal to 10 MB/sec performance

It also mentions this little gem of information

Note that the unit of performance [MB/sec] indicates 1000x1000 [Byte/sec] while the unit of data size [MB] indicates 1024x1024 [Byte]. This is because the maximum SD Bus speed is specified by the maximum SD clock frequency (25 [MB/sec] = 25000000 [Byte/sec] at 50 MHz) and data size is based on memory boundary (power of 2).

So we also have the 1000 vs 1024 "gap".

1: page 5 of this pdf

share|improve this answer
    
Shouldn't I still be seeing 10 MB/s then, not around 10 Mb/s ? –  InfinityMinusOne Nov 13 '12 at 7:54
    
The average is harder, since there is this problem of fragmentation -> if you are not using continues blocks, this can effect your speed. –  Nanne Nov 13 '12 at 8:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.