Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed NetBeans 7.2.1 for Ubuntu 12.0.4.

When I connect via FTP to a site and click view/edit a file (FileZilla), NetBeans is opened but without a file in it (it only opens NetBeans without opening the file).

Anyone had a similar issue?

Could it be permission issue?

share|improve this question
up vote 2 down vote accepted

It appears I had misconfigured file type associations in FileZilla:

It is supposed to look like this:

html /usr/bin/gedit

php /home/denis/netbeans-7.2.1/bin/netbeans

. /usr/bin/gedit

share|improve this answer
I was trying to configure it but was wrong: php home/ivan/netbeans-7.2.1/bin/netbeans (slash missed before 'home'). You made my day – quantme Dec 13 '12 at 21:12
  1. Open Filezilla.
  2. Click on Edit tab and then click on Settings.
  3. A new window will apear then click on Filetype Associations
  4. Enter path to netbeans executable for example : (php /home/denis/netbeans-7.2.1/bin/netbeans) [all php file will be open by this netbeans]
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.