Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After hearing about some of the features in 12.10, I decided to upgrade my Ubuntu from 12.04 LTS to the newer 12.10. However, when I try to upgrade it, I start the update manager, like always, and I start the distro upgrade, just like I do every time there's a new version, but at the end of the "Setting new software channels" stage, it fails, saying:

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade:
E:Unable to correct problems, you have held broken packages.

This can be caused by:

  • Upgrading to a pre-release version of Ubuntu
  • Running the current pre-release version of Ubuntu
  • Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug using the command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.

What should I do? I understand that I have some sort of "broken" package on my system, but how do I identify and remove the problem?

Note: At the start of the "Setting new software channels" stage, I was presented with this:

Third party sources disabled

Some third party entries in your sources.list were disabled. You can re-enable them after the upgrade with the 'software-properties' tool or your package manager.

** UPDATE **

Well, it was a real pain, but I actually re-downloaded the 12.04 iso, burned it to a CD (my computer has decided to stop booting from USB,) re-installed 12.04, and immediately upgraded to 12.10. I then went to sleep. When I got up in the morning, it seemed to be stalled on flashplugin-installer:downloading http://archive.canonical.com/pool/partner/adobe-flashplugin/adobe-flashplugin_11.2.202.251.orig.tar.gz.
I checked my internet, but, aside from the occasional packet bursts that keep my computer connected to my Wi-Fi, there was no usage. I think that it has stalled somehow.

Okay, it was about an hour from the time I saw the error till the time I edited this. It's been about an hour since. 2 hours stalling, plus any time that it has been doing this before I checked it - this is a serious problem. (NOTE: it already passed the "point of no return," where it said that there will be no going back after this step has been completed.)
Here's a screenshot of what it's doing: http://imgur.com/nN6kf

share|improve this question
    
The Quantal Quetzal release is too big to put on a CD, so a full reinstall isn't an option... –  JamesTheAwesomeDude Nov 13 '12 at 21:34
add comment

1 Answer 1

I know this doesn't sound like a solution to the problem, but an option people always overlook.

Do you have a USB stick? If so, download the Ubuntu 12.10 iso, plug in the USB stick, open the Dash and type 'startup'. One of the options should be 'Startup Disk Creator'. Open that and it should have listed your USB at the bottom, and at the top locate the downloaded iso. Then make the USB startup disk, insert it into the USB drive and restart.

Then you can install 12.10 straight from the USB.

Hope that's an option for you

share|improve this answer
    
No; like I said, my computer is deciding not to boot from USB. I did, after reinstalling 12.04, manage to upgrade to 12.10, though. (Because my computer messed up the first time I tried to upgrade to 12.10, I had to reinstall 12.04 again to get it to work. After 2 reinstalls and 12 hours of waiting, however, I got it to work. :) –  JamesTheAwesomeDude Nov 22 '12 at 4:33
    
Thanks for your suggestion, though. I'd tried the same thing, from Windows with PendriveLinux. That would have worked if my computer had been willing to boot from USB. –  JamesTheAwesomeDude Nov 22 '12 at 4:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.