Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Our Ubuntu server has four hard disks, but we didn't make them a RAID. Yesterday, one of the disk was reported to be failing, and this disk was /dev/sdb and was mounted as /data (was used to store data), but the server cannot boot up after we remove this disk. We tried umount it or deleted it in the 'Disk utility', but didn't work.

Is there any way to just remove this disk and avoid re-installing Ubuntu?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

The bios is failing to boot, which means it's one of two problems:

  1. The boot was installed to your data disk, solution: install grub to sda following this guide https://help.ubuntu.com/community/Grub2/Installing#Purging_.26_Reinstalling_GRUB_2
  2. Your bios requires you to have a full set of hard drives and removing one has scewered up it's internal disk reporting mechanism. this will require you to use the bios disk management tools to sort it out.
share|improve this answer
    
Thanks! It is indeed the bios' problem. I changed several configurations of the bios, and IT REALLY BOOTS! Thanks very much for saving me a lot of time for reinstalling the system. –  Andy Lu Nov 23 '12 at 12:57
    
Do you remember what the configurations where that you changed? (and please up vote) –  Martin Owens -doctormo- Nov 24 '12 at 6:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.