Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently, one of my desktops seems to have developed a problem with the fstab and mounting USB drives. The specific error I receive is...

Unable to mount TRAVELDRIVE
Error mounting: mount exited with exit code 1: helper failed with:
Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged

The contents of my fstab are...

/etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc                                       /proc           proc     nodev,noexec,nosuid                    0  0  
#Entry for /dev/sdc1 :
UUID=7e3431cd-522f-4e35-b286-4300fa702d4a  /               ext4     errors=remount-ro                      0  1  
#Entry for /dev/sda1 :
UUID=60684D08684CDE82                      /media/Archive  ntfs-3g  defaults,locale=en_US.UTF-8            0  0  
#Entry for /dev/sdc5 :
UUID=cd166221-4b1d-40f7-b9de-785208990587  none            swap     sw                                     0  0  
/dev/sdd1                                  /media/sdd1     ntfs     nls=iso8859-1,ro,users,umask=000,user  0  0  
/dev/sdd5                                  /media/PS3 (fat32)  vfat     users,user                   0  0  

/dev/sdd5                                  /media/sdd5     vfat     uid=m3talhead,users,user               0  0  

I'm guessing its a problem with the duplicate /dev/sdd5 entries (?), but being the *nix noob I am, I'm not certain.

What am I missing? Any assist is greatly appreciated!

share|improve this question
    
Do folders /media/sdd5 or /media/PS3 (fat32) exists? What happens when you try to mount by hand? 1) mkdir /mnt/test; 2) sudo mount /dev/sdd5 /mnt/test. If it works, don't forget to sudo umount /mnt/test. –  Yamaneko Nov 13 '12 at 2:47

1 Answer 1

You should not have entries in /etc/fstab for removable media; remove them.

The file fstab contains descriptive information about the various file systems. fstab is only read by programs, and not written; it is the duty of the system administrator to properly create and maintain this file.

share|improve this answer
    
could you improve the answer by placing more text with examples about what he have to do . –  Raja Nov 13 '12 at 4:07
    
So is the error I'm receiving not related to fstab? I didnt modify the file directly, only modified parameters in Storage manager. –  user107646 Nov 13 '12 at 22:09
    
@user107646, you have modified your fstab and added several entries for /dev/sdd. Take them back out. –  psusi Nov 14 '12 at 0:33
    
@psusi You said "You should not have entries in /etc/fstab for removable media." Why? If using options nofail,auto (as per askubuntu.com/a/233911/36661) why not have the entry in fstab? –  MountainX Aug 29 '13 at 0:04
    
@MountainX, because removable media are auto mounted without the need for an fstab entry, hence it is better to let that be rather than add an incorrect entry as the OP did. If you need special mount options then you should specify the UUID rather than the device ( which can change ) and the user option to prevent the error the OP got. –  psusi Aug 29 '13 at 1:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.