Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A couple of weeks ago a popup has appeared whenever I startup telling me that an application wants to access the keyring but it doesn't say which one. I'm used to seeing the application name on the popup but here it just says 'application'.

I haven't changed any passwords or did anything that might have something to do with that, to my knowledge.

I saw this question but like I said, I haven't changed any of my passwords, and I don't want my keyring password to be empty.

How can I find out which application is asking to unlock the keyring and fix it?

Here's how it looks like: alt text

share|improve this question
    
What version of ubuntu you are using?And can you post us the snapshot of the popup window? –  karthick87 Jan 15 '11 at 10:40
    
Ubuntu 10.10. And that's a negative about the snapshot, it doesn't work. The print screen key nor any of the menus seem locked. –  Idan K Jan 15 '11 at 10:43
    
I can take a picture of it using a camera if you think that'll help though. –  Idan K Jan 15 '11 at 10:49
    
what application have you installed lately that requires a password..If you joining a wireless network , make sure "available to all users is checked".. –  karthick87 Jan 15 '11 at 10:54
    
I don't think I've installed anything lately that requires a password. And I'm not joining a wireless network. –  Idan K Jan 15 '11 at 11:08

8 Answers 8

up vote 8 down vote accepted

I setup my box for auto-login and it does this on every login. In my case it's nm-applet/network-manager family of apps.

edit:
btw the problem has been around for some time, evidently some half-fix got undone during a package upgrade, but i digress...one solution is here

WHATEVER is causing the problem you could add after login but before everything else: a script with libpam-gnome-keyring to unlock it...the package to get this tool is: libpam-gnome-keyring at least in 11.04

#!/bin/bash  
#launch useful stuff for gnome
#first unlock the default keyring...  
echo YOUR_KEYRING_PASSWORD_HERE | /usr/libexec/pam-keyring-tool -u -s  
#then run nm-applet in the background...  
nm-applet &  

and the "bugs" on bugzilla are probably being continually given priority of low because it's only for autologin users. it doesn't happen "out of the box" only due to customization. just trying to help you understand why it seems like the devs don't care. it's not a coding problem, it's...well...something else.

proof video that it is nm-applet is here

and the reason it freezes the menu system is not because of gksudo, it's because it's an applet trying to start that grabs the tray and locks the menu-system. at least in my case you can still launch icons on the desktop. try putting a shortcut to a terminal there if you really must go mucking about with the prompt there.

share|improve this answer
    
I've been auto logging since forever. How do you know which app is causing it in your case? Can I somehow check what's causing it in my setup? –  Idan K Jan 20 '11 at 19:02
    
thanks for digging into this –  Idan K Jan 30 '11 at 13:30
    
np, just upsetting that i knew i was right and didn't get the bounty...but oh well. didn't meet the time constraint –  hbdgaf Jan 30 '11 at 13:33
    
I'd give you the rest of my rep if I could, if that comforts you ;) –  Idan K Jan 31 '11 at 19:29
    
again np. i could have done this digging before it expired and i didn't. my fault –  hbdgaf Jan 31 '11 at 21:09

From a security perspective, the answer is that in current distros (not just Ubuntu) you can't tell which application it is. See https://bugzilla.gnome.org/show_bug.cgi?id=574315#c4 for clarification from a gnome-keyring developer, including the security implications and scope of the task. See also http://live.gnome.org/GnomeKeyring/SecurityPhilosophy

(From a practical perspective I am also using auto-login on Ubuntu, and it seems that it is indeed nm-applet.)

share|improve this answer

I have found:

None of them have a suitable answer, which leads me to believe there is no way to find out what application is asking you to unlock the keyring.

share|improve this answer
    
please see my revised answer and video –  hbdgaf Jan 30 '11 at 13:11
    
thanks for the bug link, I've add a link to the upstream bug here and on the unix question - bugzilla.gnome.org/show_bug.cgi?id=574315 and requested comments from the developers here –  d3vid Jan 31 '11 at 9:59

Hi The key ring dialog pops up whenever ubuntu finds a wireless network.It is utility to save your secret network credentials like password etc.You can change the settings from system> Administration> Keyring manager.(I think you can find the manager here)(I don't remember the exact location sorry)

share|improve this answer
    
um...if it prompts on finding wireless networks and subsequently joins it is network-manager given the default package selection. I already noted this in a previous answer –  hbdgaf Jan 26 '11 at 20:21

You could, alternatively delete your keyring folder and Restart. That should get rid of the Password box. It will not break anything as It recreates itself using default settings :)

share|improve this answer

Okay, Goto Your Home folder Places > Home Folder And Press CTRL-H to show hidden files then navigate to .gnome2/keyrings. Look at default.keyring. If it is there or there is some sort of file called 'default' then Look at it and that is the app causing you all this issue.

share|improve this answer
    
Both of the files you mentioned are there. default contains the string default. and default.keyring seems to contain only binary data. –  Idan K Jan 20 '11 at 18:44
    
There is a file on my laptop, I will boot it up and see what it is called and then get back you you with it. I could also post a example of what it says in the name part. –  Micheal Harker Jan 20 '11 at 18:50
    
On my laptop there is no binary files :/ –  Micheal Harker Jan 20 '11 at 19:18

Run System Monitor from System - Administration and check which application is throwing the prompt.

share|improve this answer
    
When the prompt appears I can't press anything on the screen, including the System menu. –  Idan K Jan 20 '11 at 17:28

Is it possible that you've changed your password recently?

In order to see what passwords are stored in your keyring, go to "Passwords and Encryption Keys" in system -> preferences (I think - I always uninstall it as a security risk).

In that application (called Seahorse by the way), click on the "Login" keychain and either change the password on that to match your current password, or remove the password from that keychain altogether by changing it to a blank password (you'll get a warning about using "unsafe storage").

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.