Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to setup a network service for running saned (running the sane-test backend) on Ubuntu 12.10, running it on a virtualbox.

I followed the directions found here and I got to the point where if I use a front-end like xsane, or use the command scanimage -d test i get the desired behaviour. (i get the test image).

But when i try to use the network demon to access the backend (from the localhost) I get Failed to connect.

I used telnet on 127.0.0.1 6566 and i got the following error:

saned: symbol lookup error: 
saned: undefined symbol: sanei_w_init

I'm a linux newbie, so I could be making some stupid mistake. Any ideas on how to fix this?

[update] After posting this question i logged out, logged back in and it worked. After a few days I tried again and it gave the same error as before. Any help?

share|improve this question
add comment

3 Answers 3

The problem lay in having installed SANE, not knowing that it was already installed in the machine. It was the duplicate installation that was creating the mess.

share|improve this answer
add comment

The problem here is there is that you have files that Ubuntu has installed. You can easily resolve this problem however it may cause problems later on with package management.

Per the README.txt

Please check that there aren't any older versions of SANE installed on your system. Especially if SANE libraries are installed in a different prefix directory (e.g. /usr/lib/) this may cause problems with external frontends. Please remove these libraries (libsane., sane/libsane-) by using your packet manager or manually before installing this version of SANE.

Simply nuke /usr/lib/sane.

rm -rf /usr/lib/sane/*

Alternatively, things that use libsane should search in /usr/local/lib first. That's where SANE installs to.

share|improve this answer
add comment

Ola Pessoal, aqui no GNU/Linux KDu-2.0-Final eu resolvi depois de procurar instalar de varias formas , até que finalmente o Scanner esta plenamente funcional, aproveitei e crie para vocês um Script instalador, de permissões ao script e clique e esta pronto para funcionar no seu Linux base Debian / ubuntu 12.04 /12.10 em minutos o seu scanner .

http://indexdata.com.br/Linux/Drivers/Scanner/HP/hp2400c/hp2400c-hpG2410install

atenciosamente...

SuporteTecnicoID

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.