Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try playing .m4v files in VLC the sound track doesn't play correctly, and I get a kind of buzzing staticy distorted version of the actual sound, I'd really appreciate some help as I don't really like totem and XBMC doesn't seem to be working either.

Thanks in advance!

share|improve this question

4 Answers 4

Go in to the Preferences and switch the Output Module to ALSA audio output. Quit VLC & relaunch. It worked ok to me

share|improve this answer
    
Do you have a screenshoot of that menu? If you add an image (of the Preferences menu), will be more easy to the users to set the configuration as you said. –  Lucio Dec 5 '12 at 3:21
    
Did the trick for me as well, thanks. Weird its not the default. –  dolzenko Dec 8 at 15:18

For me 3 things (Easier than other options I could try) worked. You could either:

  • Change the Sound Preferences in VLC by going to Tools --> Preferences --> Sound and changing the Default from one option to another. For example Alsa to Pulseaudio or Pulseaudio to Alsa are the most common ones. enter image description here

  • Try pausing the movie for 2 to 5 seconds, then unpause it. The sound should come immediately of after 1 or 2 seconds without the horrible static.

  • If you are using HDMI or outputting it to a TV/Monitor with Speakers and already checked all the Sound settings in your TV or Monitor, try changing the Sound Preferences in Ubuntu:

    enter image description here

share|improve this answer

I've had the same problems with VLC sound playback in various formats. Go in to the Preferences and switch the Output Module to Pulseaudio audio output.
Quit VLC & relaunch.

Hope it helps!

share|improve this answer

Solution #23 worked for me for 2 computers for skype and vlc that made problems with sound: pulseAudioBugWebSite

The solution is to change the lines in /etc/pulse/default.pa. I've changed this line:

load-module module-udev-detect

to this:

load-module module-udev-detect tsched=0

reboot. It worked for me!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.