Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I think the following will explain my concern for not wanting to choose Y.

oshirowanen@desktop:~$ sudo aptitude full-upgrade
The following NEW packages will be installed:
  libavcodec53{a} libavutil51{a} 
The following packages will be upgraded:
  libavdevice53 libavformat53 libpostproc52 libproxy1 libproxy1:i386 libproxy1-plugin-gsettings libproxy1-plugin-networkmanager 
  libswscale2 python-libproxy 
9 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,804 kB of archives. After unpacking 7,233 kB will be used.
The following packages have unmet dependencies:
 libavutil-extra-51 : Conflicts: libavutil51 but 4:0.8.4-0ubuntu0.12.04.1 is to be installed.
 libavcodec-extra-53 : Conflicts: libavcodec53 but 4:0.8.4-0ubuntu0.12.04.1 is to be installed.
open: 418; closed: 3160; defer: 214; conflict: 420                                                                                     oThe following actions will resolve these dependencies:

       Remove the following packages:                                                                                           
1)       bluez-alsa:i386                                                                                                        
2)       frei0r-plugins                                                                                                         
3)       glib-networking:i386                                                                                                   
4)       google-earth-stable                                                                                                    
5)       gstreamer0.10-ffmpeg                                                                                                   
6)       gstreamer0.10-plugins-bad-multiverse                                                                                   
7)       gstreamer0.10-plugins-base:i386                                                                                        
8)       gstreamer0.10-plugins-good:i386                                                                                        
9)       gstreamer0.10-x:i386                                                                                                   
10)      gtk2-engines:i386                                                                                                      
11)      gtk2-engines-murrine:i386                                                                                              

( and many more only deleted due to limited characters allowed in question )                                                                                            

247)     melt                                                                                                                   
248)     odbcinst1debian2:i386                                                                                                  
249)     openshot                                                                                                               
250)     python-mlt3                                                                                                            
251)     vlc                                                                                                                    
252)     vlc-nox                                                                                                                
253)     vlc-plugin-notify                                                                                                      
254)     vlc-plugin-pulse                                                                                                       
255)     xaw3dg:i386                                                                                                            
256)     zlib1g:i386                                                                                                            

       Keep the following packages at their current version:                                                                    
257)     libavcodec53 [Not Installed]                                                                                           
258)     libavutil51 [Not Installed]                                                                                            

       Leave the following dependencies unresolved:                                                                             
259)     ubuntu-restricted-addons recommends gstreamer0.10-ffmpeg                                                               
260)     ubuntu-restricted-extras recommends gstreamer0.10-plugins-bad-multiverse                                               
261)     libcanberra-gtk0:i386 recommends libcanberra-gtk-module:i386                                                           
262)     libncurses5:i386 recommends libgpm2:i386                                                                               
263)     libncursesw5:i386 recommends libgpm2:i386                                                                              
264)     libslang2:i386 recommends libpng12-0:i386                                                                              
265)     libvisual-0.4-0:i386 recommends libvisual-0.4-plugins:i386                                                             
266)     libgphoto2-2:i386 recommends udev:i386 (>= 0.175)                                                                      
267)     libgphoto2-2:i386 recommends libgphoto2-l10n:i386 (>= 2.4.13-1ubuntu1.2)                                               
268)     libqt4-dbus:i386 recommends qdbus:i386 (= 4:4.8.1-0ubuntu4.3)                                                          
269)     libqt4-sql:i386 recommends libqt4-sql-mysql:i386 | libqt4-sql-odbc:i386 | libqt4-sql-psql:i386 | libqt4-sql-sqlite:i386


Accept this solution? [Y/n/q/?] 

Any idea how to correct this?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted
sudo apt-get update
sudo apt-get upgrade --full-resolver

The --full-resolver flag should solve your issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.