Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some reason, I can't see the home directory share that maps to each user's home directory, [homes]. I can directly map the network drive to it in windows or mount it on a Mac, but when trying to browse all available shares it doesn't show up. I've tried setting the [homes] share to browseable = no and browseable = yes without any success. Here is my smb.conf:

[global]
    # Custom edits via hook
    #######################

    # enable symlinks outside of shares
    unix extensions = no
    wide links = yes

    browseable = Yes
    # End custom edits
    ###################
    netbios name = enterprise
    workgroup = LIFE
    server string = Zentyal File Server

    wins support = yes
    dns proxy = yes
    name resolve order = wins bcast host

    interfaces = lo,eth0
    bind interfaces only = yes

    server role = dc
    server role check:inhibit = yes
    realm = LIFE.LAN

    log level = 3
    log file = /var/log/samba/samba.log

    passdb backend = samba4
    idmap_ldb:use rfc2307 = yes
    server services = -dns -nbt -wrepl
    server signing = auto



[netlogon]
    path = /var/lib/samba/sysvol/life.lan/scripts
    browseable = no
    read only = yes

[sysvol]
    path = /var/lib/samba/sysvol
    read only = no

[homes]
    comment = Home Directories
    path = /home/%S
    read only = no
    browseable = no
    create mask = 0611
    directory mask = 0711
    vfs objects = acl_xattr full_audit
    full_audit:success = connect opendir disconnect unlink mkdir rmdir open rename
    full_audit:failure = connect opendir disconnect unlink mkdir rmdir open rename

# Shares
[directories]
    comment = Home directories
    path = /home
    browseable = Yes
    read only = No
    force create mode = 0660
    force directory mode = 0660
    vfs objects = acl_xattr full_audit
    full_audit:success = connect opendir disconnect unlink mkdir rmdir open rename
    full_audit:failure = connect opendir disconnect unlink mkdir rmdir open rename
# Shares
[default]
    comment = A share for anything
    path = /home/samba//shares/default
    browseable = Yes
    read only = No
    force create mode = 0660
    force directory mode = 0660
    vfs objects = acl_xattr full_audit
    full_audit:success = connect opendir disconnect unlink mkdir rmdir open rename
    full_audit:failure = connect opendir disconnect unlink mkdir rmdir open rename
# Shares
[scan]
    comment = Printer scans
    path = /home/samba//shares/default/Scanned
    browseable = Yes
    read only = No
    force create mode = 0660
    force directory mode = 0660
    vfs objects = acl_xattr full_audit
    full_audit:success = connect opendir disconnect unlink mkdir rmdir open rename
    full_audit:failure = connect opendir disconnect unlink mkdir rmdir open rename


[print$]
    comment = "Printer Drivers"
    path = /var/lib/samba/printers
    browseable = yes
    read only = yes
    guest ok = no
    write list = @"Domain Admins"
    valid users = @"Domain Users"

#[zentyal-internal-backups]
# path = /tmp
# browseable = yes
# read only = yes
# valid users = @"Domain Admins"
# admin users = @"Domain Admins"
# force group = ebox
# force user = ebox

[zentyal-quarantine]
    comment = "Quarantine"
    path = /home/samba/quarantine
    browseable = Yes
    read only = No

# Custom Share
# Generated by hook
[intranet]
    comment = intranet
    path = /var/www/ministries
    browseable = Yes
    read only = No
    force create mode = 0660
    force directory mode = 0660
    vfs objects = acl_xattr full_audit
    full_audit:success = connect opendir disconnect unlink mkdir rmdir open rename
    full_audit:failure = connect opendir disconnect unlink mkdir rmdir open rename

[ministries]
    comment = ministries
    path = /var/local/ministries
    browseable = Yes
    read only = No
    force create mode = 0660
    force directory mode = 0660
    vfs objects = acl_xattr full_audit
    full_audit:success = connect opendir disconnect unlink mkdir rmdir open rename
    full_audit:failure = connect opendir disconnect unlink mkdir rmdir open rename
share|improve this question

3 Answers 3

If you are trying to browse them from the samba server then the problem is the lo interface binding.

Using interfaces = lo,eth0 will only bind 127.0.0.1 and eth0 IP. For some reason loopback access is done via 27.0.1.1.

Either add 127.0.1.1/8 to interfaces or remove bind interfaces only = yes

interfaces = 127.0.1.1/8 lo,eth0
bind interfaces only = yes
share|improve this answer
    
Unfortunately I am trying to connect from another computer (both a Mac and a Windows machine). Could the lo interface binding affect this? –  Gabriel Syme Nov 19 '12 at 14:30

Try using [home] instead of [homes] as section name and only these options:

comment = Home Directories
path = /home/%S
read only = no
share|improve this answer

I don't know samba4 but for samba3 this is explained in the SPECIAL SECTIONS of man page.

   The [homes] section
       If a section called [homes] is included in the configuration file, services connecting clients to their home directories can be
       created on the fly by the server.
...
       The browseable flag for auto home directories will be inherited from the global browseable flag, not the [homes] browseable flag.
       This is useful as it means setting browseable = no in the [homes] section will hide the [homes] share but make any auto home
       directories visible.

Maybe you can set browsable flag to yes in the global section.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.