Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I fix the permissions to get rid of the following error and mount my USB and internal CD/DVD drive:

Adding read ACL for uid 1000 to `/media/bret' failed: Operation not supported

These drives worked fine in 12.04, but I apparently now don't have permissions to mount these drives in 12.10. I tried chmod in the terminal, but I couldn't enter as the superuser, so I seem to be stuck. Please help!

share|improve this question

If becoming superuser is the only problem, then do

sudo su root  

(a user who has proper privileges can use sudo to become superuser using her/his own password.)

share|improve this answer

I'm also looking for an answer to this problem. I posted a question, which wasn't answered. But I've just found some info - its a bug that has been reported - see href="">

This page gives an answer which seems to be working for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.