Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed Ubuntu 12.10 on a brand new SSD. The benchmarking program super_pi is not working, telling me that the executable pi is not found. The pi program is contained within the extracted folder of the archive. Has anyone else had this problem and been able to solve it? I've had no issue with super_pi on Linux Mint 12 and Debian Squeeze.

In general, why would linux tell me the program is not found, when it is right there?

Even trying to invoke it directly with "./pi" does not work. Any ideas?

Edit: The exact commands I have tried are:

  • sh superpi.sh 20
  • ./superpi.sh 20
  • ./pi 20

All with the same error: "Error executing 'pi': No such file or directory"

share|improve this question
maybe the executable dont have execution permission: chmod +x pi? –  Salem Nov 12 '12 at 17:28
Would you please show us the exact command that you are running? –  InkBlend Nov 16 '12 at 18:09
Now it is segfaulting... at least the strange not found error went away. Where can I get a good copy of this software? –  parker.sikand Nov 18 '12 at 0:17
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.