Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A few days ago, my computer started feeling very slow, and looking a CPU usage, I saw that even the simplest processes required a lot of CPU.

As far as I can tell, it's because the core are all down-clocked to 800Mhz, and won't up-clock again when it's needed.

$ cat /proc/cpuinfo | grep MHz
cpu MHz     : 800.000
cpu MHz     : 800.000
cpu MHz     : 800.000
cpu MHz     : 800.000

As a test, I then start up BOINC, to load all my cores to the max, using htop, I see all cores running at > 95%.

My cpu scaling settings:

$ for governor in $(ls /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor); do cat $governor; done
ondemand
ondemand
ondemand
ondemand

With 'ondemand, I expect the core to clock up, and go to full power, but a watch shows them steady on 800.

To get better performance, I need to manually force it:

sudo bash -c 'for governor in $(ls /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor); do
  echo"performance" > $governor;
done'

Whch immediately changes the frequency to:

$ cat /proc/cpuinfo | grep MHz
cpu MHz     : 2701.000
cpu MHz     : 2701.000
cpu MHz     : 2701.000
cpu MHz     : 2701.000
share|improve this question
    
Is ignore_nice_load set to 1? Try using stress to simulate cpu load. –  psusi Nov 12 '12 at 16:10
    
askubuntu.com/questions/285434/… –  Qasim Jun 14 '13 at 14:36
add comment

1 Answer 1

cat /proc/cpuinfo | grep MHz (or grep MHz /proc/cpuinfo) will only show you the standard clock speeds.

If you want live CPU frequency settings, you need something a little beefier. I know powertop works but for a something convenient all the time, indicator-cpu could be worth it:

sudo apt-get install indicator-cpufreq
indicator-cpufreq

You'll need to add indicator-cpufreq to the things to run at start-up, or you'll have to run it manually each login.

share|improve this answer
    
Actually when I installed indicator-cpufreq from the normal repos it added itself to the start-up items. I didn't have to do it manually. Ubuntu 12.10. –  To Do Nov 12 '12 at 13:10
    
Ok, I looked in powertop since I already had it installed, and I still see essentially 0% in the higher frequencies, even when I load all cores to 100%. –  user50849 Nov 12 '12 at 14:12
1  
No, it shows the current clock speeds, as you can see from the different values he posted in the question. –  psusi Nov 12 '12 at 16:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.