Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Samsung NP900X3C.

I have problem with occasionally connecting to WIFI, with Ubuntu 12.10. Sometimes my computer could not connect to WIFI "blab", neither after reboot computer.

Only solution is to restart WIFI hotspot. It's public WIFI, used by many users, that don't have that problem.

My /var/log/syslog:

 Nov 12 10:09:39 k15 wpa_supplicant[1308]: wlan0: SME: Trying to authenticate with 64:70:02:89:7c:d7 (SSID='blab' freq=2427 MHz)
 Nov 12 10:09:39 k15 kernel: [    8.908610] wlan0: authenticate with 64:70:02:89:7c:d7
 Nov 12 10:09:39 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: scanning -> authenticating
 Nov 12 10:09:39 k15 kernel: [    8.915032] wlan0: send auth to 64:70:02:89:7c:d7 (try 1/3)
 Nov 12 10:09:39 k15 wpa_supplicant[1308]: wlan0: Trying to associate with 64:70:02:89:7c:d7 (SSID='blab' freq=2427 MHz)
 Nov 12 10:09:39 k15 kernel: [    8.916753] wlan0: authenticated
 Nov 12 10:09:39 k15 kernel: [    8.916839] wlan0: waiting for beacon from 64:70:02:89:7c:d7
 Nov 12 10:09:39 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: authenticating -> associating
 Nov 12 10:09:39 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: associating -> disconnected
 Nov 12 10:09:39 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: disconnected -> scanning
 Nov 12 10:09:42 k15 wpa_supplicant[1308]: wlan0: SME: Trying to authenticate with 64:70:02:89:7c:d7 (SSID='blab' freq=2427 MHz)
 Nov 12 10:09:42 k15 kernel: [   12.386212] wlan0: authenticate with 64:70:02:89:7c:d7
 Nov 12 10:09:42 k15 wpa_supplicant[1308]: wlan0: Trying to associate with 64:70:02:89:7c:d7 (SSID='blab' freq=2427 MHz)
 Nov 12 10:09:42 k15 kernel: [   12.389114] wlan0: send auth to 64:70:02:89:7c:d7 (try 1/3)
 Nov 12 10:09:42 k15 kernel: [   12.391021] wlan0: authenticated
 Nov 12 10:09:42 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: scanning -> authenticating
 Nov 12 10:09:42 k15 kernel: [   12.391332] wlan0: waiting for beacon from 64:70:02:89:7c:d7
 Nov 12 10:09:42 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: authenticating -> associating
 Nov 12 10:09:43 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: associating -> disconnected
 Nov 12 10:09:43 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: disconnected -> scanning
 Nov 12 10:09:46 k15 wpa_supplicant[1308]: wlan0: SME: Trying to authenticate with 64:70:02:89:7c:d7 (SSID='blab' freq=2427 MHz)

and after restart WiFi, I could connect:

 Nov 12 10:11:51 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: inactive -> scanning
 Nov 12 10:11:55 k15 wpa_supplicant[1308]: wlan0: SME: Trying to authenticate with 64:70:02:89:7c:d7 (SSID='blab' freq=2427 MHz)
 Nov 12 10:11:55 k15 kernel: [  144.445154] wlan0: authenticate with 64:70:02:89:7c:d7
 Nov 12 10:11:55 k15 kernel: [  144.453994] wlan0: send auth to 64:70:02:89:7c:d7 (try 1/3)
 Nov 12 10:11:55 k15 wpa_supplicant[1308]: wlan0: Trying to associate with 64:70:02:89:7c:d7 (SSID='blab' freq=2427 MHz)
 Nov 12 10:11:55 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: scanning -> authenticating
 Nov 12 10:11:55 k15 kernel: [  144.455860] wlan0: authenticated
 Nov 12 10:11:55 k15 kernel: [  144.458681] wlan0: associate with 64:70:02:89:7c:d7 (try 1/3)
 Nov 12 10:11:55 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: authenticating -> associating
 Nov 12 10:11:55 k15 kernel: [  144.462799] wlan0: RX AssocResp from 64:70:02:89:7c:d7 (capab=0x431 status=0 aid=9)
 Nov 12 10:11:55 k15 kernel: [  144.486368] wlan0: associated
 Nov 12 10:11:55 k15 wpa_supplicant[1308]: wlan0: Associated with 64:70:02:89:7c:d7
 Nov 12 10:11:55 k15 kernel: [  144.487435] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
 Nov 12 10:11:55 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: associating -> associated
 Nov 12 10:11:55 k15 NetworkManager[1004]: <info> (wlan0): supplicant interface state: associated -> 4-way handshake

This problem is appearing regulary.

My WiFi device control is nl80211.

 Nov 12 10:09:32 k15 NetworkManager[1004]: <info> (wlan0): using nl80211 for WiFi device control
 Nov 12 10:09:32 k15 NetworkManager[1004]: <warn> (wlan0): driver supports Access Point (AP) mode
 Nov 12 10:09:32 k15 NetworkManager[1004]: <info> (wlan0): new 802.11 WiFi device (driver: 'iwlwifi' ifindex: 3)
 Nov 12 10:09:32 k15 NetworkManager[1004]: <info> (wlan0): exported as /org/freedesktop/NetworkManager/Devices/0
 Nov 12 10:09:32 k15 NetworkManager[1004]: <info> (wlan0): now managed
 Nov 12 10:09:32 k15 NetworkManager[1004]: <info> (wlan0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
 Nov 12 10:09:32 k15 NetworkManager[1004]: <info> (wlan0): bringing up device. 
share|improve this question
add comment

1 Answer

please install the following program I hope that it work

Wicd Network Manager

please tell me if it works

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.