Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently tried to upgrade/update my graphics drivers in Ubuntu 12.04. Now the screen is all zoomed to a 640 x 480 resolution and I can't figure out how to undo what I did. How can I revert to the old situation?

share|improve this question
3  
For what it's worth, and I'm not sure why but I managed to get back my old screen resolution by doing the following: sudo apt-get purge xserver-xorg sudo apt-get install xserver-xorg xserver-xorg-video-all sudo reboot –  John B Nov 13 '12 at 6:25

2 Answers 2

If it was the nvidia current or current updates driver that was installed, you can remove them with:

sudo apt-get remove nvidia-current

and

sudo apt-get remove nvidia-current-updates

respectively. If neither of these packages can be removed then try the following command to install the nouveau driver as I believe it will make it current in any case. To remove a driver other than nvidia-current or nvidia-current-updates we will need to know exactly what it was that you installed.

If you want to make sure the current open source nouveau driver is installed, do

sudo apt-get install xserver-xorg-video-nouveau

Since you're still having trouble, re-install the current driver then see if you can set a better resolution with nvidia-settings.

sudo apt-get install nvidia-current

then type 'nvidia settings' into the dash and click on the icon it finds. Resolution can be found under the tab 'Xserver Display Configuration' If that works save the settings.

If it doesn't work, then repeat the exercise but install nvidia-current-updates then run nvidia-settings again.

share|improve this answer
    
I did exactly as you said, but the problem is still there. I did install an nvidia driver (the 173 version). I've tried installing nouveau, but how can I make the OS actually use it? –  John B Nov 12 '12 at 16:45
    
I've tried doing sudo apt-get remove nvidia-173, as well as removing the nvidia blacklist file in /etc/modprobe.d, but when I reboot I'm still running into the same issue. –  John B Nov 12 '12 at 18:31
    
See the ammended information, we'll try the specific drivers again. You need to tell us the result of running the commands (not removed, removed etc) because we're all flying blind here. –  fabricator4 Nov 12 '12 at 19:26
    
When I ran sudo apt-get remove nvidia-current, I get:Package nvidia-current is not installed, so not removed. Same when I do sudo apt-get remove nvidia-current-updates. When I run sudo apt-get install xserver-xorg-video-nouveau, i get "xserver-xorg-video-nouveau is already the newest version." –  John B Nov 13 '12 at 6:01
    
When I run sudo apt-get install nvidia-current I get: "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server." I run nvidia-xconfig as root, but that just results in the same error. –  John B Nov 13 '12 at 6:09

also another option to look into use using the nvidia console and changing the resolution to the proper size for your display, or using Jupiter to change the resolution (Which I have now found to be the quickest option for switching resolutions)

sudo add-apt-repository ppa:webupd8team/jupiter
sudo apt-get update
sudo apt-get install jupiter

and then from unity launch Jupiter and it will be a small indicator where you can then change resolution and screens.

share|improve this answer
1  
Hmm I don't think it's a resolution issue. Either way, when I go to the Displays system page, the only resolution option I get is 640 x 480. –  John B Nov 12 '12 at 17:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.