Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to get any output to my external monitor on 12.10. The monitor is recognized and shows the native res (1920x1080, correct) but enabling has no effect. Graphics chipset is Intel Ironlake (Arrandale).

I have tried:

  • Full system update after installing
  • Oibaf PPA updated drivers (https://launchpad.net/~oibaf/+archive/graphics-drivers)
  • Enabling SNA
  • Kubuntu 12.10 (in addition to Ubuntu 12.10) Both were fresh installs.

Nothing works, any troubleshooting ideas? Everything is fine on 11.10.

UPDATE 1: Also tried using Intel drivers from Xorg-Edgers PPA (https://launchpad.net/~xorg-edgers/+archive/ppa) Still no output on HDMI.

UPDATE 2: Just tried Lubuntu 12.10, same issue. It appears that any 12.10 downstream distro will likely have this issue.

UPDATE 3: Output from 'xrandr -q'

user@testbox:~$ xrandr -q
Screen 0: minimum 320 x 200, current 3286 x 1080, maximum 8192 x 8192
LVDS1 connected 1366x768+0+312 (normal left inverted right x axis y axis) 256mm x 144mm
   1366x768     60.0*+
   1360x768     59.8    60.0  
   1024x768     60.0  
   800x600      60.3    56.2  
   640x480      59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1080+1366+0 (normal left inverted right x axis y axis) 598mm x 337mm
   1920x1080    60.0*+   50.0  
   1680x1050    59.9  
   1680x945     60.0  
   1400x1050    74.9    59.9  
   1600x900     60.0  
   1280x1024    75.0    60.0  
   1440x900     75.0    59.9  
   1280x960     60.0  
   1366x768     60.0  
   1360x768     60.0  
   1280x800     74.9    59.9  
   1152x864     75.0  
   1280x768     74.9    60.0  
   1280x720     60.0    50.0  
   1024x768     75.0    70.1    60.0  
   1024x576     60.0  
   800x600      72.2    75.0    60.3    56.2  
   720x576      50.0  
   848x480      60.0  
   720x480      59.9  
   640x480      75.0    72.8    60.0  
   720x400      70.1  
DP1 disconnected (normal left inverted right x axis y axis)

UPDATE 4: 'xrandr -q' output from Oneiric, HDMI working fine:

user@ptero:~$ xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
LVDS1 connected (normal left inverted right x axis y axis)
   1366x768       60.0 +
   1360x768       59.8     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 337mm
   1920x1080      60.0*+
   1680x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        60.0  
   720x400        70.1  
DP1 disconnected (normal left inverted right x axis y axis)
share|improve this question
add comment

3 Answers

Confirmed not working on 12.10 but was working on 12.04 I checked today. Different TV mine is Insignia. xranr has relatively identical output (aside from resolution differences)

share|improve this answer
add comment

I've reported a similar problem here for Ubuntu 12.10, Dell XPS 14 ultrabook, and an Optoma HD20. Other projectors work fine. How to I debug blank display on a specific model of projector?

I've tried adding the modeline as described above, to no avail: the display is still blank, even though Displays recognizes that an external monitor is attached

EDIT: I submitted this launchpad bug: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1112859

share|improve this answer
add comment

Please query your outputs and add listing to your question:

xrandr -q

Thus we will see your outputs listed.

Possible way with using xrandr can be:

Step 1. Create mode line by using gtf

gtf 1920 1080 60.0

Step 2. Create new mode for xrandr

xrandr --newmode <value of your modeline without word "Modeline">

Step 3. Add new mode to output

xrandr --addmode HDMI1 1920x1080_60.00 

And if commands above DON'T bring any errors:

Step 4. Choose your new mode

xrandr --output HDMI1 --mode 1920x1080_60.00

also can help switch script with LVDS1 disabling (save to .sh file and run):

#!/bin/bash
if [[ $(xrandr -q) == *"HDMI1 connected"* ]]
then
    xrandr --output LVDS1 --off
    xrandr --output HDMI1 --auto
else
    xrandr --output LVDS1 --auto
fi

At Charles'Blog I found pretty explained script written for 11.10:
Ubuntu 11.10 – Automatic HDMI Toggle (with audio!)

Update 1

For testing output please try:

share|improve this answer
1  
As you can see from the xrandr output I added above, the system indicates the monitor is connected and working at the proper resolution. I've tried non-native resolutions for testing, nothing works. I performed your 4 steps anyway, substituting 'HDMI1' for 'HDMI-0', but the only things that happened was that step 4 briefly woke the monitor from standby for a few seconds. –  Veazer Nov 21 '12 at 0:50
    
If my HDMI was working, that toggle script would be handy :) –  Veazer Nov 21 '12 at 19:33
    
ok, sunny ... for test: disable SNA, remove Xorg-Edgers drivers, and test your HDMI output again on any other suitable driver ... so if it will work means that it was incorrect driver package. –  swift Nov 22 '12 at 0:10
    
It was broken from the start, SNA and Xorg-Edgers were last ditch attempts to get HDMI working, so i tried HDMI heavily before adding those. As for the intellinuxgraphics drivers, those are what is in the Oibaf PPA, also not working unfortunately. What is the most appropriate place to file a bug report for this? No output to my monitor on 12.10 or any downstream distro is disturbing... –  Veazer Nov 22 '12 at 6:49
    
so maybe it's problem with a monitor? If xrandr shows that HDMI1 connected then ports is operable. Also, your config shows common desktop: LVDS1: 1366x768+0+312 and HDMI1: 1920x1080+1366+0, where 1366 & 312 shifts by x & y. It seems normal multihead cfg should be 1366x768+0+0 and 1920x1080+0+0 –  swift Nov 22 '12 at 7:30
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.