Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently purchased the WNA1100 WiFi Adapter for my Ubuntu Server 12.04 Box. Since I'm new to Ubuntu, I'm unable to install the drivers for the WiFi Adapter. I found that the WiFi adapter uses the Atheros AR9271 chipset. I downloaded the htc_9271.fw file from the Linux Wireless site.

How do I install the driver?

share|improve this question

You may need both files there; htc_9271.fw and htc_7010.fw. Both are mentioned in:

    modinfo ath9k_htc

Please open at terminal and do:

    cd Desktop   <--or wherever the downloaded files are
    sudo cp htc_9271.fw /lib/firmware
    sudo cp htc_7010.fw /lib/firmware

Now unload and reload the driver:

    sudo modprobe -r ath9k_htc && sudo modprobe ath9k_htc
share|improve this answer

I recommend you return the card and purchase something that's already supported:

You are probably used to wrestling with driver annoyances in Windows and therefore think it's pretty normal. In Linux, it isn't. If you have to wrestle with drivers, it's because your card isn't actually supported - you may be able to get it to work, but you're usually better off just returning it and getting something that IS supported, which will "just work" without needing to fight with it.

share|improve this answer
NO! It is supported, see:… The WNA1100 is supported by the Atheros driver & firmware under Linux. – danger89 Feb 11 '15 at 16:25
you realize you replied to a nearly three year old answer, right? at the time OP posted his or her question, that was unsupported hardware. – Jim Salter Mar 2 '15 at 17:48

Just unplug and plug back your usb adapter.

This worked for me after reconnecting the device!

share|improve this answer
But you didn't need to install any driver? Because this isn't plug&play – Lucio Dec 29 '12 at 15:57

This was not working for me and I was banging my head against wall. Until I run apt-get update && apt-get upgrade.

The recent upgrade solved the issue, and the card is working with charm.

Ubuntu: 13.04 Kernel: 3.8.0-30-generic #44-Ubuntu

share|improve this answer

@Jim Salter If you check the site you gave you will find that Netgear WNA 1100 is supported:




Need only a .deb packet

Download the last version of the and execute the .deb packet. Connect the WiFi adapter"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.