Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed Ubuntu 12.10 in VMware Player and have came up with a black sidebar, missing icons, a pretty broken GUI. Everything works just fine though. I am able to run Firefox and open termainal and all that good stuff just fine, it's just that

I can SEE them on the sidebar. I have to open up a seperate window on Windows with a picture of the Ubuntu 12.10 desktop in order for me to know what to click on, but once I do click on it, it's pretty much smooth sailing from there(not counting closing Firefox and several other things).

Again, everything works just fine, but when it comes to the sidebar, the GUI, the dashboard (get a completely black screen for when I open dash board), they come up as completely black, broken (visual tears and what not), and hoving over them just brings up a big black bar (assuming it's the "zooming" in of the icon, but it just shows a black bar of where the icon should be). I'm not exactly sure what so do to get this to work (to fix the GUI), any ideas as to what I may do to fix this?

share|improve this question

You should disable 3D graphics acceleration.

  • Firstly, shutdown Ubuntu.
  • Then go to Virtual Machine SettingsHardwareDisplay → un-check Accelerate 3D graphics.
  • Lastly, start the Virtual machine.
share|improve this answer

I had something similar using a kvm virtual machine. Maybe it is related to the fact that ubuntu detects the display as a laptop display.

I fixed it by resetting the theme. Go to system settings/appearance and select ambiance (default). When selecting high contrast, it pretty much goes black again.

share|improve this answer

Shutdown the Ubuntu VM machine, then click on:

VMSettingHardwareDisplay → un-check Accelerate 3D graphics → OK

Start the machine again and check.

share|improve this answer

protected by jokerdino Dec 1 '13 at 17:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.