Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i am trying to run my first Android application with Eclipse Juno on Ubuntu 12.04

I downloaded the ADT and the Android SDK, all worked fine as far as i could see, but when i create my first android application, the emulator does not start, and nothing shows up in the console.

The project is in the left panel, but if i try to run it, nothing happens. I tried the 'run configurations' work-around, and it says me that:

No active compatible AVD's or devices found. 
Relaunch this configuration after connecting a device or starting an AVD.

So i think that the problem is the emulator, but even if I go to the avd manager and start the virtual device, the same error is showing up. I can't delete and re-create the virtual device because it says that the emulator is running and it owns the virtual device.

What can I do? I can't believe i'm not able to run the simplest android application :)

edit: if I go to run-->run configurations and set my virtual device as default device, I got

Android Launch!
adb is running normally.
Performing android.love.HaikuDisplay activity launch
Automatic Target Mode: Preferred AVD 'standard' is not available. Launching new emulator.
Launching a new emulator with Virtual Device 'standard

But nothing happens. What should I do?

share|improve this question
1  
Can you start emulator using AVD Manager ? Does homescreen show up ?, its either emulator-side problem or Eclipse being unable to connect to emulator –  Nevercom Nov 18 '12 at 18:20
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.