Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I simply do not have the option for "two-finger scrolling" available in my "Mouse and Touchpad" settings. I have tried a lot of terminal commands that I have found in the forums with no success. Who has a solution that will enable two-finger scrolling?

A little about me:

Ubuntu 12.04.1 LTS \n \l

Built-in Pointing Device
    Type: Mouse
    Interface: PS/2
    Buttons: 2

~$ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Synaptics TouchPad                   id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ WebCam SC-13HDL10931N                     id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=14   [slave  keyboard (3)]

Screenshot of system settings:

share|improve this question
    
Have you tried utouch,touchegg? Have you read this answer? –  Hckr Nov 11 '12 at 23:32
    
I have tried touchegg, getting more errors that have to do with my own ineptitude. But was unable to solve the problem. In any case, its my understanding that 12.04 ships with these settings built-in. Why aren't mine here? –  Ian Nov 11 '12 at 23:49
    
Please provide the output of the following command: grep -i synaptic /var/log/dmesg. Maybe you can find there something. –  Salem Nov 12 '12 at 0:26
    
Also, there's this link that may help you. –  Salem Nov 12 '12 at 0:36
1  
I'm pretty sure that the device has to be able to support two finger scrolling to have it enabled. –  iKiel2012 May 1 '13 at 0:06

2 Answers 2

First you should try if any of the following group of commands enables the two-finger scrooling:

synclient VertTwoFingerScroll=1
synclient HorizTwoFingerScroll=1

synclient EmulateTwoFingerMinW=5
synclient EmulateTwoFingerMinZ=48

If it works, then you can either create a script to enable this as suggested here, or using xorg.conf.

Source:

share|improve this answer
    
Thank you again Salem, I get the following message: Couldn't find synaptics properties. No synaptics driver loaded? –  Ian Nov 12 '12 at 0:02
    
Followup: Synaptics touchpad drivers are installed, verified in ubuntu software center but no ouput when using synclient -l command: ~$ synclient -l Couldn't find synaptics properties. No synaptics driver loaded? –  Ian Nov 12 '12 at 0:09
    
Anyone have an idea? Still working on this... –  Ian Nov 12 '12 at 17:36

The solution described here worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.