Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So today I popped out my hdd with ubuntu on it and put in a fresh hdd and installed win8 (wanted to try it). I got everything installed, upp and running and decided to go back to ubuntu (for obvious reasons lol) but when I boot back into ubuntu my internet connection will not connect. I booted into a live cd of ubuntu and it still would not work. I thought I blew up my onboard port so i booted back into win8 and the internet worked without flaw. so i booted back into my ubuntu install and i have a usb to ethernet adapter that im using but i still cant get my onboard to connect. any ideas?

lspci output:

jeffy@jeffy:~$ lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] nee ATI Radeon Xpress 200 Host Bridge (rev 01)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RS480 PCI Bridge
00:11.0 IDE interface: Advanced Micro Devices [AMD] nee ATI IXP SB400 Serial ATA Controller (rev 80)
00:12.0 IDE interface: Advanced Micro Devices [AMD] nee ATI IXP SB400 Serial ATA Controller (rev 80)
00:13.0 USB controller: Advanced Micro Devices [AMD] nee ATI IXP SB400 USB Host Controller (rev 80)
00:13.1 USB controller: Advanced Micro Devices [AMD] nee ATI IXP SB400 USB Host Controller (rev 80)
00:13.2 USB controller: Advanced Micro Devices [AMD] nee ATI IXP SB400 USB2 Host Controller (rev 80)
00:14.0 SMBus: Advanced Micro Devices [AMD] nee ATI IXP SB400 SMBus Controller (rev 82)
00:14.1 IDE interface: Advanced Micro Devices [AMD] nee ATI IXP SB400 IDE Controller (rev 80)
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI IXP SB4x0 High Definition Audio Controller (rev 01)
00:14.3 ISA bridge: Advanced Micro Devices [AMD] nee ATI IXP SB400 PCI-ISA Bridge (rev 80)
00:14.4 PCI bridge: Advanced Micro Devices [AMD] nee ATI IXP SB400 PCI-PCI Bridge (rev 80)
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RC410 [Radeon Xpress 200]
02:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:06.0 FireWire (IEEE 1394): LSI Corporation FW322/323 (rev 61)
share|improve this question
add comment

4 Answers 4

regarding your description i think this is what could be happen:

if you shutdown windows, it usually turns of NIC by default which will be enabled again after rebooting.. this affects dual-boot systems pretty often.. This means you won't be able to get a working network connection on linux.

there are a lot of ways how to enable NIC again. this can be done in your BIOS, over windows or linux.

here you will find some solutions how to fix your problem:

( see section: Realtek no link / WOL issue )

https://wiki.archlinux.org/index.php/Network_Configuration#Realtek_no_link_.2F_WOL_issue

hope this helps!

share|improve this answer
    
I don't have a dual boot environment tho. The win install HDD is not physically attached and the Ubuntu HDD wasn't attached when I installed win I will which the bios for the nic –  h4x0rj3ff Nov 12 '12 at 12:27
    
yea i know, but in fact you started windows which might have turned off NIC in your BIOS and afterwards you went back to ubuntu without enabling NIC first.. so it is possible that it is still turned off and to fix this problem you should try the fixes shown in the link.. –  Christopher Jahnke Nov 12 '12 at 14:20
add comment

It might be a BIOS bug, try unplugging the power cord for 30 seconds, then back in (or removing the battery in case of a laptop).

share|improve this answer
    
I do not completely understand how this is happening, but it worked! The only operating system is Ubuntu. –  Pavel A Jan 22 '13 at 16:25
add comment

The issue is originating dual-boot(Windows)

I think the solution is:

  • Boot up Windows
  • Right click on My Computer
  • Click on Properties -> Hardware -> Device Manager
  • Expand your network card section and double click on your Realtek network card
  • Set "Wake-on-lan after shutdown" to enabled

http://www.linuxquestions.org/questions/linux-networking-3/realtek-8139-8168-8169-on-2-6-21-3-or-newer-593495/

share|improve this answer
    
ok so i got it! i couldnt find the option for wake on lan after shutdown so i just disabled the card and booted into ubuntu! everything is up running and working properly!!! thank you all!!! –  h4x0rj3ff Nov 12 '12 at 23:04
add comment

I recommend you try executing this command

echo on | sudo tee /sys/class/net/eth0/device/power/control

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.