Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After updating the kernel to 3.5.0-18 the Broadcom BCM43228 wireless card of my Acer Aspire One 756 has stopped working properly. The card often refuses to connect to my AP, and if it connects it behaves very unstable.

I have already reinstalled the drivers, as recommended by googling around. As far as I can tell the only driver that supports my card is the bcmwl package. I found one solution saying I should install broadcom-sta using module assistant, however I could not get this to install and apparently broadcom-sta and bcmwl are effectively the same driver?

Is anyone experiencing similar issues? Is it possible to just downgrade to the previous kernel version?

share|improve this question

closed as off topic by Jorge Castro, Luis, devav2, Stephen Myall, fossfreedom Nov 13 '12 at 16:32

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Welcome to Ask Ubuntu! This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  Jorge Castro Nov 12 '12 at 0:43
    
Hi Ignition, this is the main reason why I was working on the answer to this link: askubuntu.com/questions/55868/… –  Luis Nov 12 '12 at 15:13

3 Answers 3

The instructions below worked for me

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl
iwconfig

Edit: If you have problems turning on the card as I do use this

rfkill list all
rfkill unblock all
share|improve this answer

Please run:

    lspci -nn | grep 0280

Is your pci.id 14e4:4359? If so, please do:

    sudo apt-get install linux-headers-generic
    sudo apt-get install --reinstall bcmwl-kernel-source

Reboot and your wireless should be working.

share|improve this answer

It is possible to downgrade to the previous kernel version.

If you didn't remove older kernel packages, first try older kernel version.When grub screen appears, choose Advanced options for ubuntu and then choose ubuntu which is with your older kernel version.If your issue doesn't occur, remove newer kernel packages from synaptics and restart your computer.

If grub screen doesn't appear when booting, press Shift in order to open grub menu.

If you removed older kernel packages, first install them and try above.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.