Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i am new at linux and ubuntu, today i installed ubuntu 12.04 but during installation some problem happened, i don't remember what was that exactly (but can tell you that it was related to boot), so i reinstalled ubuntu (using usb stick both time) and ubuntu installation finished successfully,

Now problem is that when I start my computer then system is directly selecting ubuntu as my operating system, i have installed it along with windows 7 in option during installation, so it should give me option to select which operating system i want to use. I don't know what may be the problem.

Also, I want to know where ubuntu is installed (which directory)? i just selected default setting during installation as i am noob in these things.

/** i think i found problem, problem is that during startup the selection of operating system is hidden behind this square box saying that 'out of range 92.5khz / 58hz' , i was able to guess windows 7 option will be last so using my sense i can choose operating system now. but now again new problem that message (i think there is some screen resolution problem so desktop is unable to display window saying that out of range),

i have no idea how to solve this problem now.) */

---- solution--------

GRUB. I download GRUB Customizer and change the resolution of the screen and now I can see all the menu!

share|improve this question

closed as too localized by fossfreedom Nov 19 '12 at 16:43

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Welcome to Ask Ubuntu! When you installed Ubuntu, did you boot your machine from the LiveUSB, or did you install it in Windows using Wubi? –  Christopher Kyle Horton Nov 11 '12 at 17:01
    
i installed it using live usb –  samsher Nov 11 '12 at 17:07
    
Could you run the BootInfoScript and paste it's output here? It'd be useful for future visitors to help you out :) –  nitstorm Nov 11 '12 at 17:42

4 Answers 4

As someone explained, Sudo Update-grub should have done it for you , If not , You must restart ,Then at the beginning of boot before Ubuntu even dares to try to show up , Click Shift

Click Shift , Click Multiple or Hold , Then it says Loading Grub Then you have your options , Click the recovery mode , And you can update grub from one of the options there , That is like a Back-up if the Terminal Commands fail you.

If that doesn't work , Then you might need to re-install Windows , I am having trouble with that myself so I can't help you there.

share|improve this answer
    
it shows windows 7 in terminal during use of sudo udate-grub, and you mean i am having to hold shift+multiply symbol key during startup to get recovery mode? –  samsher Nov 11 '12 at 17:22
    
@samsher To force the GRUB2 menu to show at boot, you should only need to hold down the Shift key while the machine is starting. From there you should be able to select recovery mode from the menu. –  Christopher Kyle Horton Nov 11 '12 at 18:52
    
Sorry I didn't reply in time but warrior understood what I meant , I meant It might need multiple presses or Holding the key , I hope you solve your problem –  Ubisoft Terzuz Nov 11 '12 at 19:50
    
problem solved, i've answered in the question about problem. –  samsher Nov 12 '12 at 2:38

Install grub customizer and change the boot splash wait time http://webupd8.org/2012/09/grub-customizer-30-released.html

share|improve this answer

Open the Terminal (Ctrl+Alt+T) and type

sudo update-grub
share|improve this answer
    
it says sudo: grub: command not found @srinivas –  samsher Nov 11 '12 at 17:04
    
yes it worked now, what it will do btw? –  samsher Nov 11 '12 at 17:10
    
restart your comp –  Srinivas Gowda Nov 11 '12 at 17:11
1  
install grub customizer and change the boot splash wait time webupd8.org/2012/09/grub-customizer-30-released.html –  Srinivas Gowda Nov 11 '12 at 17:16
1  
@WarriorIng64 posted my comment as a new answer. –  Srinivas Gowda Nov 12 '12 at 6:57

either of the following would have happened

  • grub, which allows multiple system to be configured perhaps dosen't contain windows boot details.
  • or grub has the entry but it has selected ubuntu has default operating system and the selection time is kept at a low value, because of this reason its boot by default in Ubuntu.

in any case you will have to the following

share|improve this answer
    
i'm filling shame but how to get etc/grub/menu.lst file? –  samsher Nov 11 '12 at 17:17
    
I don't think there is a /etc/grub/menu.lst file in 12.04 since 12.04 uses Grub2. And once again @gnuyoga please do post comments when requesting the OP for further information. Thanks :) –  nitstorm Nov 11 '12 at 17:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.